Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've got several Mac OS X 10.6 clients who connect to our Windows 2000 & 2003 File Servers - No Active Dir, just file shares.

I'm finding that the Mac clients keep lots of connections open on our server, even when they have no files open. My tests show that just browsing the folders using Finder keeps all of the folders open. Windows "Computer Management" shows these sessions with 15-20 open files, and these are causing us to reach our connection limit and locking down the server.

I've disabled the creation of DS_Store, thinking that was the problem, but it was not. Also, tried disabling named streams - no luck.

I ran a test - A Mac client browsed to a folder called "AFolder" with one file called "Program.doc", then navigated to another folder, and recorded the activity with ProcMon on the server (W2K):

From computer manager, you can see that the folder “D:\Shared\AFolder” is still open, and thus dozens of folders stay open when they browse around (even after closing finder):

I tested the same thing with Mac OS X 10.5.7 and it did not have that problem. Here is the ProcMon results:

I'm not too familiar with these file operations, can anyone tell whats causing this?

The best I can tell by comparing the 10.5 and 10.6 logs, is that 10.6 does a CreateFile D:\Shared\AFolder, and then never closes it, even after I navigate out to a different folder. Whereas, 10.5 does close the folder.

share|improve this question
    
Did you ever solve this? I'm seeing similar issue... –  user78810 Apr 18 '11 at 21:57
    
No, we decided to move to a linux file-server. Trying clearos right now –  Pete Shack May 3 '11 at 20:07
    
I seriously surprised this issue isn't getting more attention, I guess the problem is going by different names, I thought it was a permissions issue for so long. –  Keith Loughnane Oct 25 '12 at 12:15
add comment

1 Answer

It could be as simple as Spotlight (the MacOS Search mechanism) is indexing those files once the shares are mounted. I believe that there is a preference to turn off the indexing of network shares.

I don't have facilities to test right now, but you could try:

  • Try running mdutil -i off /path/to/volume to turn off indexing for the relevant volume. If that works you could set it up as a script to run at startup or login.

  • You could also try creating an empty file called ".metadata_never_index" and placing that at the root of the network mount point. It should prevent spotlight from indexing the folder and subfolders (at least under that mountpoint.)

share|improve this answer
    
Thanks, I just tried both suggestions, rebooted, but the open connections still keep accumulating. So it doesn't seem to be spotlight. –  Pete Shack Oct 27 '10 at 15:37
    
@Pete Shack - Sorry, then. I've got nothing else for you... –  gWaldo Oct 27 '10 at 17:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.