Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem using htaccess url rewrite on a symbolic folder. Below is the line which i am using in htaccess file for url rewriting.

RewriteRule ^global/css/([0-9]+)/([a-z-_]+)\.css$ global/less/index.php?site_id=$1&file=$2 [L]

"global" is my symbolic directory

This rule works fine when I use it on other then symbolic directory. But it does not work on symbolic directory.

it is working on my live server but not working on my local test server. what other configuration is required to make it work.

Any solution?

share|improve this question

3 Answers 3

up vote 0 down vote accepted

I ran across a similar problem, try looking in your httpd.conf file, check to see if you have an alias set to your global link, if so, try commenting it out and restart your server.

share|improve this answer
    
it worked. thanks –  user57221 Oct 17 '10 at 19:21

debug mod_rewrite: use RewriteLog and RewriteLogLevel directive(http://httpd.apache.org/docs/2.2/mod/mod_rewrite.html#rewritelog):

<VirtualHost *:80>

....

RewriteLog "/var/log/rewrite.log" 
RewriteLogLevel 8

</VirtualHost> 
share|improve this answer

Try this...

Options +FollowSymlinks
RewriteEngine On
RewriteRule ^global/css/([0-9]+)/([a-z-_]+)\.css$ global/less/index.php?site_id=$1&file=$2 [L]
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.