Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to configure apache to listen on port 8079
I added LISTEN 8079 directive in httpd.conf
I opened 8079 port in iptables / restarted iptables etc. I even stopped iptables service.
"netstat -nal | grep 8079" shows "tcp 0 0 :::8079 :::* LISTEN"

Now, if I try to access localhost:8079 or myserver.com:8079 from that machine, I can access that page
BUT from any other machine I am not able to access the site on any port other than 80. On port 80, it works. On port 8079 it does not.

what else do I need to configure???? Please help.

If it matters, I use centOS server. You can see my httpd.conf file here fileuploading.net/860467 I am not using any third party software - compiled apache, tomcat and jk connector from source.

Thanks

UPDATE:::::::: It was a firewall issue. There was a hardware firewall that was blocking access to almost all ports. (Turning off software firewall / SELinux bla bla had no effect)

Then I scanned the open ports and used the port that was open. (came to know about this command many days later)

If you are facing the same problem, Run the following command

sudo nmap -T Aggressive -A -v 127.0.0.1 -p 1-65000

It will scan for all the open ports on your system. Any port that is open can be accessed from outside.

Ref.: http://www.go2linux.org/which_service_or_program_is_listening_on_port

share|improve this question
    
Can you amplify how it doesn't work? Presumably you are getting "connection refused" or similar? What do nmap or wget from other computer say? –  RedGrittyBrick Oct 15 '10 at 11:44
    
Could not connect to server through browser wget says connection refused. –  vivek.m Oct 15 '10 at 11:47
1  
You've got firewall issues, this has nothing to do with Apache. –  Chris S Oct 15 '10 at 14:19
    
yeah chris, it is a firewall issue and I am supposed to solve it ;) –  vivek.m Oct 29 '10 at 19:10
add comment

2 Answers 2

up vote 0 down vote accepted

Do you perhaps have a hardware firewall or similar device between the other machines and this webserver? If so, the firewall might be port forwarding connections incoming on port 80 on the firewall from the test machines to go to port 8079 on the webserver instead, and you will need to modify the firewall's configuration.

share|improve this answer
    
yeah, your aswer is almost correct. I had to get information about hardware firewall from someone else. And you proved right :-) Anyway, there's a simpler way i.e. of port scanning. Check my answer. –  vivek.m Oct 23 '10 at 12:53
add comment

You disabled firewall from Centos? execute setup command, then go to "Firewall configuration" and on "Security Level" mark Disabled option.. I also had problem with that.

Neto

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.