Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a domain www.tahirakram.com. I have configured blog.tahirakram.com with my posterous blog. For that I just added A record with the IP address provided by posterous. And it was working fine.

I want to make a site on www. Means www.tahirakram.com or tahirakram.com will point to my own hosting. For this I registered a hosting account on 000webhost. I added their nameservers.

But now my subdomain is not working. Only www.tahirakram.com points to 000webhost. Rest nothing. Even without www its not working. And subdomain too.

Please help.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

You need to add a new A record to your 000webhost DNS settings like you did to configure blog.tahirakram.com the first time. You can also add another A record for "@" pointing to the same IP as "www" is pointing to in order to get it to work without the www.

This is because all of your DNS settings for tahirakram.com must be in the same place. When you added 000webhost's nameservers, you changed it so that all of your DNS settings are there on their nameservers instead of wherever they were before (probably whoever you registered your domain through).

share|improve this answer
    
It works. Thanks. –  Tahir Akram Oct 17 '10 at 20:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.