Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is the process i did to install the certificate:

What i have is:

  • Vps running Cent OS
  • Cpanel/Whm/LAMP
  • SSL certificate
  • 2 IPs ( One of them which is the main )
  • 1 Domain name which is running nicely using regular HTTP

What i did is:

I generated a key & a csr and i issued an SSL, i opened whm and selected "Install a SSL Certificate and Setup the Domain" i've pasted the certificate and it automatically fetched it, i changed the IP to the secondary IP ( because if i didn't, it says you should have a dedicated ip ) , and a message says "SSL installed successfully".

But when i go to test it i get the firefox error "SSL received a record that exceeded the maximum permissible length." which means like the SSL is not installed.

The domain name servers point to the main ip, i tried to change them to the secondary where the ssl have been installed but still doesn't work.

( i tried to use "nobody" when installing the SSL and it works but it's not a reliable way and some errors happen too )

So what's the solution?

Thank you

share|improve this question
    
When you say "i issued an SSL", do you mean you issued a self-signed certificate instead? –  Bruno Oct 16 '10 at 20:43

2 Answers 2

"SSL received a record that exceeded the maximum permissible length." can occur for a number of reasons, a common one is that SSL isn't enabled (it's not really an error that would occur for an invalid/non-trusted certificate).

Try http://your.host.name:443/ (instead of https://your.host.name/). If this works, it means that there is indeed something listening on port 443 (default for HTTPS), but that SSL isn't enabled. There should be SSLEngine on in your VirtualHost configuration (on that port).

share|improve this answer

Was the common name in your CSR the name of the domain you are trying to install the SSL cert on? The domain the SSL cert is for must mach the common name in your CSR

share|improve this answer
    
Yes, it's the same. –  Tom Oct 16 '10 at 15:39
    
@Tom: What your apache config look like for the site in question? –  Dan McClain Oct 16 '10 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.