Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a FreeBSD 64bit running on a esxi 4.1, the hardware platform is a DELL R710 with 2 x 56xx (intel 6core cpu) and 48 GB ram.
The FreeBSD vm is very slow, when we compiles/builds something on it, it takes 5 minuts and it says "build time 18 seconds.".
There's no vmtools installed on the vm.
The same vm is installaed on another R710 running esxi 4.0 for dell and there's no problems with that one. Does anyone have any idea about what to look for?

the VMs on the second server (ESXi 4.1) is a clone of the VMs running on the first VMserver (ESXi 4.0 Dell edition).
It's not possible for me to move the VM back to the first server since the file contaning the vm is too big. We installed the new esxi with a datasore with 8mb blocks because 1mb blocks dident allow for the file size we needed. It looks like the www server on the new ESXi 4.1 works fine, but I havent really tested it.
There's not installed vmtools on any of the VMs (FreeBSD). The block size on the second VM (ESXi 4.1) datastorage is 8mb and 1mb on the first (ESXi 4.0)

share|improve this question
7  
Why isnt VMWare Tools installed? –  pauska Oct 18 '10 at 9:06

4 Answers 4

I'm going to ask again: Why isn't vmware tools installed?

If you absolutely refuse to install it, try kern.hz=100 in /boot/loader.conf

Also make sure you run NTPD to keep time consistent.

share|improve this answer

Looks very much like a timing issue, probably related to clock interrupts.
You really should install VMware tools on that server.

share|improve this answer

Install the kernel modules (aka tools). As root:

cd /usr/ports/emulators/vmware-tool6
make install clean
share|improve this answer

I would:

  • make sure that ESX is not swapping RAM: check the vm's Resource Allocation tab
  • make sure that the underlying datastore is not under load: look at its performance tab and make sure nothing is using it while isolating the problem
  • make sure there is no CPU and RAM limits set on this vm: check that vm's Edit Settings > Resources tab doesn't show that this VM has no limits set
  • check that if this vm belongs to a resource pool, how its Resource Allocation tab looks like (a nice table showing all the limits and shares in one go)
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.