Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to compile PHP 5.3.3 and after a lot of ups and downs, I finally did 'make' it followed by 'make install' which just shows this:

root@server [/tmp/php-5.3.3]# make install
Installing PHP SAPI module:       cgi
Installing PHP CGI binary: /usr/bin/
Installing PHP CLI binary:        /usr/bin/
Installing PHP CLI man page:      /usr/share/man/man1/
Installing shared extensions:     /usr/lib64/20090626/
Installing build environment:     /usr/lib64/build/
Installing header files:          /usr/include/php/
Installing helper programs:       /usr/bin/
  program: phpize
  program: php-config
Installing man pages:             /usr/share/man/man1/
  page: phpize.1
  page: php-config.1
/tmp/php-5.3.3/build/shtool install -c ext/phar/phar.phar /usr/bin
ln -s -f /usr/bin/phar.phar /usr/bin/phar
Installing PDO headers:          /usr/include/php/ext/pdo/

It does not look like its done, because /usr/lib64/httpd/modules/libphp5.so still shows an old date:

-rwxr-xr-x 1 root root 3193768 Mar 31  2010 libphp5.so
share|improve this question

3 Answers 3

up vote 1 down vote accepted

You need build apache2handler:

$./configure --with-apxs2

Then clean build directory and build php:

$make clean
$make
$make install

Read: http://www.php.net/manual/en/install.unix.apache2.php

share|improve this answer
    
Didnt' quite work - said "Sorry, I cannot run apxs. Possible reasons follow: 1. Perl is not installed 2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs 3. Apache was not built using --enable-so (the apxs usage page is displayed)" –  siliconpi Oct 18 '10 at 12:07
    
Where / how can I download this apxs module? Please dont tell me that I have to make/compile apache as well!! –  siliconpi Oct 18 '10 at 12:08
    
install httpd-dev –  bindbn Oct 18 '10 at 14:51
    
Thanks - that set me on the correct path! –  siliconpi Oct 19 '10 at 2:51

In the ./configure of php is possible that you select a prefix, but it is not necessary and you can compile with only ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql.

share|improve this answer

Of course it didn't update mod_php. You told it to build cgi instead.

share|improve this answer
    
Did I?? I took the ./configure options from what PHP 5.1.6 "Configure Command" showed me in phpinfo() before upgrading. –  siliconpi Oct 18 '10 at 11:49
    
Well, your output above reads "cgi". –  Ignacio Vazquez-Abrams Oct 18 '10 at 11:52
    
You're right - trying to work on the --with-apxs2 option... –  siliconpi Oct 18 '10 at 12:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.