Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an ESX 3.5 update 5 cluster of five host servers, all fully patched as of this Friday. Today I noticed that one of the servers has the Hardware Health status as unknown in Virtual Center Infrastructure Client. When I look at the Health Status view under configuration for that host, all the items are status Unknown.

The server is exactly the same configuration as the others - same model (HP DL360 G5), memory, NICs etc.

I have tried restarting the management service with service mgmt-vmware restart but this has not resolved the issue.

Asides from this, I am not seeing any issues with the cluster - however, I hate having a blind spot like this.

Any ideas?

share|improve this question

2 Answers 2

Actually, there's an other way to perform this (or better, to try to), using the VSphere Direct Console User Interface (DCUI), connecting directly to the physical server (with keyboard and monitor). On your screen, you'll have a "gray and yellow" style window, in which, pressing F2 (Configure system), you'll be prompt to login (user root and the password you set) and then you'll get this menù:

EDIT: image removed due to antispam rules. Here the link to image.

Select the "Restart Management Agents" option, confirm with F11, and press Return when done. That's it.

I solved the "unknown status" issue just doing that, without using console commands or neither stopping the virtual machines and reboot the physical server.

Hope this help. Bye.

share|improve this answer
up vote 0 down vote accepted

Ok - I fixed this. The following steps did not resolve the issue:

  • service mgmt-vmware restart on the affected host
  • putting the host into maintenance mode, then detaching it from the cluster and reattaching

However, once I'd tried this and since it was in maintenance mode anyway, I rebooted the host, and when it came back online, the Host Health was reporting again.

share|improve this answer
    
Do you have plans to move to v4.x? I've seen far fewer weird anomalies such as this since moving over. –  Chopper3 Oct 19 '10 at 19:43
    
Most definitely. I can't believe we are still on 3.5... –  dunxd Oct 19 '10 at 19:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.