Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a ReadyNAS on my network that I can't SSH or rsync into because it doesn't allow connections on port 22. I can, however, see the machine in Ubuntu's filesystem GUI under "Network". If I open up the ReadyNAS's folder there, I can see all the files I'm interested in.

How can I get to these files from the command line so that I might copy them via a cp command? I already tried sudo find / -name 'filename' and nothing turned up.

My overall goal is to copy the files from the ReadyNAS onto my Linux box via a script.

Edit: I found what may be a clue. My share is called gob and my ReadyNAS is called Galapagos_NAS and I found the following files in my home folder:

/home/jason/.local/share/gvfs-metadata/smb-share:server=galapagosnas.local,share=gob
/home/jason/.local/share/gvfs-metadata/smb-share:server=galapagosnas.local,share=gob-4f3182b8.log

Also, the ReadyNAS documentation says that to connect to the ReadyNAS from Linux, you can do this:

mount <ipaddr>:/<backup /backup>

where backup is the share name which, in my case is gob. According to the instructions, I should be able to do

sudo mount 192.168.140.2:/gob /gob

But I get an error: mount: mount point /gob does not exist. I don't know why this is or how to try to fix it.

Edit 2: I created a directory /home/jason/gob and now I'm running this command:

sudo mount 192.168.140.2:/gob /home/jason/gob/

And getting this error:

mount: wrong fs type, bad option, bad superblock on 192.168.140.2:/gob,
       missing codepage or helper program, or other error
       (for several filesystems (e.g. nfs, cifs) you might
       need a /sbin/mount.<type> helper program)
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

And here's this:

$ dmesg | tail
[   20.816764] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   22.675899] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   28.384106] eth1: no IPv6 routers present
[   29.658406] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
[   31.736021] eth0: no IPv6 routers present
[   99.689403] RPC: Registered udp transport module.
[   99.689408] RPC: Registered tcp transport module.
[   99.689410] RPC: Registered tcp NFSv4.1 backchannel transport module.
[   99.807517] FS-Cache: Loaded
[   99.891512] FS-Cache: Netfs 'nfs' registered for caching

I don't know what to do next.

share|improve this question
    
You do have a local directory /gob, don't you? –  MadHatter Oct 18 '10 at 15:40
    
No, I don't. Apparently I should? –  Jason Swett Oct 18 '10 at 15:46
    
Yes, the "mount point" refers to an existing directory where you want the filesystem mounted, so you need to create an empty directory for this purpose. –  DerfK Oct 18 '10 at 15:57

1 Answer 1

up vote 0 down vote accepted

Well your NAS box is clearly sharing using one protocol or another - probably CIFS/SMB - so try mounting the box that way, it might be NFS or FTP but I'd start via CIFS/SMB first.

share|improve this answer
    
Yes, it's sharing using CIFS. As for "mounting the box that way," can you really spell it out for me? I'm new to this. Thanks. –  Jason Swett Oct 18 '10 at 15:35
    
mount.cifs //*IP-address*/*mount-name* /mnt/*mount-point* -o username=*userID*,password=*password*,domain=*domain* –  Chopper3 Oct 18 '10 at 15:37
    
Hmm, I don't think it needs or wants a username/password. If you look at my edit on my question, the mount command in the ReadyNAS documentation doesn't use one. If I take the username part out of your command, I still get the same error as when I try the command from the ReadyNAS docs. –  Jason Swett Oct 18 '10 at 15:50
    
The fix was a variation of your answer: sudo mount.cifs 192.168.140.2:/gob /home/jason/gob/ after creating /home/jason/gob. –  Jason Swett Oct 18 '10 at 17:08
    
Yeah sorry, you need to create the mount point first. –  Chopper3 Oct 18 '10 at 17:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.