Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to setup a test vpn between my home desktop and my laptop. So far I have got the server on the desktop to connect fine but I can not get my laptop to finish the connection. I have tried several different configurations and they all give me the same result. Obviously it has nothing to do with my Client configuration but possibly something on my laptop?

Here is the message I get in the log when it stops then times out and restarts.

Mon Oct 18 20:10:55 2010 UDPv4 link local: [undef]
Mon Oct 18 20:10:55 2010 UDPv4 link remote: 74.190.29.236:1194
Mon Oct 18 20:11:55 2010 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Mon Oct 18 20:11:55 2010 TLS Error: TLS handshake failed

here are my configurations

server.ovpn

port 1194
proto udp
dev tun
ca ca.crt
cert server.crt
key server.key
dh dh1024.pem
server 10.8.0.1 255.255.255.252
ifconfig-pool-persist ipp.txt
push "route 10.0.0.1 255.255.255.0"
push "dhcp-option WINS 10.0.0.5"
push "dhcp-option DNS 10.0.0.5"
push "dhcp-option DOMAIN acme.com.local"
keepalive 10 120
comp-lzo
max-clients 1
persist-key
persist-tun
status openvpn-status.log
verb 3

LArry.ovpn

client
proto udp
dev tun
remote doublel.hopto.org 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert client1.crt
key client1.key
comp-lzo
verb 3
dev tun
local 206.162.148.9
remote 134.28.54.2
ifconfig 192.168.99.1 192.168.99.2
route 10.0.0.0 255.0.0.0 192.168.99.2

I just need a simple vpn for one user. Am I headed down the right path?

Thanks, Larry

share|improve this question
    
sorry forgot to include my configurations –  user57515 Oct 19 '10 at 0:27
    
Please learn how to embed preformatted text in your questions (it makes it a lot easier to read configuration files). Documentation on the appropriate syntax is here. –  larsks Jan 13 '11 at 1:04
    
...and it makes the multiline log messages actually intelligible. –  larsks Jan 13 '11 at 1:10
add comment

1 Answer 1

  1. Can you telnet doublei.hopto.org 1194?

  2. Have you generated certificates using the software in easy-rsa (AFAICR) in documentation?

share|improve this answer
    
I can ping doublel.hopto.org and I have generated the certificates. The log message has been the same on my laptop regardless of whether I use certificates or a static key. –  user57515 Oct 19 '10 at 15:03
    
replying to ping doesn't mean that the port is open on the server, check firewall rules –  Hubert Kario Oct 19 '10 at 16:06
    
+1 for @Hubert; this sounds like a network connectivity problem. Replying to ping simply means your system responds to ICMP, but it doesn't tell you that (a) there is something listening on the right port or (b) whether or not there are firewall rules preventing the connection. To answer part of your question, I use OpenVPN all the time for connections between my laptop (and my phone!) and my home network, and it's worked out great. I think you're doing the right thing. –  larsks Jan 13 '11 at 1:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.