Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Building boost with macports falls causes a cc1plus process to run forever. Anyone know anything about this? (BTW, port is version 1.710 and I'm running OS X 10.5.6 with kernel 9.6.0)

$ port install boost
--->  Fetching boost
--->  Attempting to fetch boost_1_38_0.tar.bz2 from http://superb-east.dl.sourceforge.net/boost
--->  Verifying checksum(s) for boost
--->  Extracting boost
--->  Applying patches to boost
--->  Configuring boost
--->  Building boost
share|improve this question
    
Intel or PPC processor? –  Chealion Jun 4 '09 at 6:03
    
Intel. Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386 i386 –  user7965 Jun 4 '09 at 18:48

1 Answer 1

up vote 1 down vote accepted

Have you tried running sudo port -d install boost to enable debug messages in hopes of finding out what it's stuck on?

share|improve this answer
    
Just tried that but neither -v or -d (or both) show more output. –  user7965 Jun 4 '09 at 18:52
    
Oh, it's actually "port -d install", not "port install -d". I'm running it at the moment. –  user7965 Jun 4 '09 at 18:54
1  
A lot of files are being compiled; perhaps it just takes a long time. I'm still monitoring it. –  user7965 Jun 4 '09 at 19:09
1  
OK, it finished. Took half an hour but it finished. Thanks for the suggestion, I'd consider that the answer ;-) –  user7965 Jun 4 '09 at 20:08
    
Sorry bout the flag in the incorrect position. Bad memory. –  Chealion Jun 5 '09 at 4:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.