Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm newbie in IIS 7.5 , Before this I used to run ASP.NET Website under IIS 5 , That was too easy .

I'm trying to run a very simple asp.net website ( just created a new website from VS 2010 targeted in .net 3.5) in IIS 7.5.7600 on windows 7 Ultimate 64 bit .

While adding application , during Test Setting i receive one warning that says :

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that \$ has Read access to the physical path. Then test these settings again

But I don't know how to make sure application pool identity has read access to the physical path ?

I'm wondering if there is any step by step article or some thing that show me the walk-though for running a simple asp.net website on IIS 7.5?

I appreciate any help .

share|improve this question

1 Answer 1

for the error you are receiving

you'll probably need to look at using a local user account on each system with the same name and password. When you connect from ServerA to ServerB, which based your description are in a workgroup , having the same user id and password will help get over authentication issues between machines.

Another option would be to look at NULL sessions, which in itself is a security risk. Here is more information on NULL sessions.

http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a4939515-b651-4ee0-b327-867b31fd8c9a.mspx?mfr=true

I would recommend going the route of using local accounts with the same password.


if you still have the message, try this

In ADD VIRTUAL DIRECTORY, select CONNECT AS and enter an administrator and the pass. Then all should be allowed or enter a user who has full access to the location

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.