Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed virtualmin on my nice shiny new rackspace cloud. Everything went seemlessly but I've been having some issues getting emails to send properly. The problem seems to be that the server can not send mail to email addresses where the domain is owned by my server.

For example, on my server I run multiple virtual domains, lets call this one test.com. When I run the mail command from shell (mail user@test.com) I get the following back from my maillog:

Oct 6 14:55:18 test postfix/pickup[8737]: DC1131612CC: uid=0 from= 
Oct 6 14:55:18 test postfix/cleanup[8769]: DC1131612CC: message-id=20101006145518.DC1131612CC@server.test.com 
Oct 6 14:55:18 test postfix/qmgr[8738]: DC1131612CC: from=root@server.test.com, size=353, nrcpt=1 (queue active) 
Oct 6 14:55:18 test postfix/error[8771]: DC1131612CC: to=me@example.co.uk, relay=none, delay=0, delays=0/0/0/0, dsn=5.0.0, status=bounced (User unknown in virtual alias table) 
Oct 6 14:55:18 test postfix/cleanup[8769]: DD07D1612D1: message-id=20101006145518.DD07D1612D1@server.test.com 
Oct 6 14:55:18 test postfix/bounce[8772]: DC1131612CC: sender non-delivery notification: DD07D1612D1 
Oct 6 14:55:18 test postfix/qmgr[8738]: DD07D1612D1: from=<>, size=2268, nrcpt=1 (queue active) 
Oct 6 14:55:18 test postfix/qmgr[8738]: DC1131612CC: removed 
Oct 6 14:55:18 test postfix/local[8773]: DD07D1612D1: to=root@server.test.com, relay=local, delay=0.03, delays=0/0/0/0.03, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME) 
Oct 6 14:55:18 test postfix/qmgr[8738]: DD07D1612D1: removed

when I run mail me@gmail.com the message is sent and received perfectly fine. I'm a bit of a noob when it comes to servers, but I pick things up fairly quickly, so please excuse any incorrect terminology and my general noobiness.

Any help would be greatly appreciated, I've been googling for quite a while but I haven't found a solution yet, I'll add a copy of my main.cf file in a response below

cheers guys


here is the reformatted postconf, do you want the reformatted main.cf file too, or is this enough?

alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
broken_sasl_auth_clients = yes
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
home_mailbox = Maildir/
html_directory = no
mailbox_command = /usr/bin/procmail-wrapper -o -a $DOMAIN -d $LOGNAME
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
myhostname = server.test.com
newaliases_path = /usr/bin/newaliases.postfix
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
sample_directory = /usr/share/doc/postfix-2.3.3/samples
sender_bcc_maps = hash:/etc/postfix/bcc
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_recipient_restrictions = permit_mynetworks permit_sasl_authenticated reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
unknown_local_recipient_reject_code = 550
virtual_alias_maps = hash:/etc/postfix/virtual
share|improve this question

1 Answer 1

User unknown in virtual alias table

should be the problem. As the file is /etc/postfix/virtual, could you check it ? Do you have rehash it with postmap /etc/postfix/virtual ? Don't forget to create a root account for this domain if you want to use it...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.