Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server doesn't boot and I found that /etc/fstab file is empty.
When trying to update this file I see that the file is readonly.
I can't change the write permission, becuase the device is mounted readonly.
I can't remount with rw permission I get an error saying that the / doesn't appear in the /etc/fstab file.
Any ideas?

share|improve this question

1 Answer 1

When you remount the drive, refer to it by device name rather than simply /. If it's mounted read only, you should be able to see the device name if you run mount with no parameters. Then, run mount -o remount,rw /dev/xxxx / and it should be accessible again.

share|improve this answer
    
This should work. However, I would wonder how/why /etc/fstab has been truncated. It is possible that the root filesystem is seriously borked, so it might not be a good idea to mount it rw until after a fsck. –  Steven Monday Oct 19 '10 at 14:12
    
I managed to mount to the device and to update the fstab file. –  user57559 Oct 21 '10 at 5:22
    
I managed to mount to the device and to update the fstab file. Now I still have the problem: "fsck.ext2 /dev/root ... e2fsck -b 8193 <device>" I tried severals superblock values, but still it doesn't work. Any ideas? –  user57559 Oct 21 '10 at 5:26
    
Check that /dev/root actually points to the right partition? If the partition can be mounted at all, you shouldn't need any -b superblock option to fsck it. If it's telling you it can't find an ext2fs superblock on it, then it's probably telling you the truth... is the partition really ext2 and not reiser or xfs? –  DerfK Oct 21 '10 at 6:04
    
How can I check that? I'm new with Linux. –  user57559 Oct 21 '10 at 6:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.