Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have reports that I/O on a certain filesystem, namely /srv/data1, is intermittently horrific. I've seen it myself and it's true. For example, I run 'ls' /srv/data1 and the output takes 30+ seconds to appear. I run it again and this time, no delay. The periods of OK and horrific are short and cycle rather rapidly.

/srv/data1 is a 500GB OCFS2 on /dev/drbd1, which in turn is on systemA:/dev/md3 and systemB:/dev/md3. A and B are identical Dell R610s running SLES11. On both A and B /dev/md3 is a mirror of /dev/sdc1 and /dev/sdd1. And those are 500 GB SATA drives used for nothing else. The HDD controller is Dell's PERC 6/iR.

This is a busy, busy master Subversion server and the delays are breaking some processes that keep remote proxy servers in sync with this master. That's causing trouble for the development teams.

Any thoughts?

Thanks, Mike

share|improve this question

2 Answers 2

up vote 1 down vote accepted

I determined that we'd simply reached the limit of the system. We moved the data onto an EMC SAN LUN and it's an order of magnitude faster now.

share|improve this answer

Are you mounting with default options ? If there are multiple nodes in ocfs2 cluster and write activities, try using noatime option or another relative-modfified-time options at least.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.