Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I've got this setup ...

Fiber cable broadband connection -> Media Converter -> Switch (8 ports) -> PCs The network does not have DHCP, all settings are manual.

3 computers can connect to the Internet (all Windows XPs, with any IP I throw at them), another 3 computers cannot connect (2 Windows, 1 Linux)

The ISP is not doing any MAC filtering.

Here's what I tried:

  • getting rid of the Switch / direct connection to one of the non-working computers
  • restarting Switch / Media Converter
  • switching cables around
  • switching IPs around
  • MAC spoofing - to see if the ISP is doing any MAC filtering
  • since the Windows PCs could have caught viruses I also tried a laptop with Linux (which I know it can connect without problems on other networks wired or wireless)

All computers not-working are signaling to me that the connection could be made, no problem with the drivers, but when pinging the Gateway or anything else, I get "Request timed out" (on Windows) and "Destination Host Unreachable" (on Linux).

On Linux, when doing an "ip route ls", I get this:

84.43.5.70/28 dev eth0  proto kernel  scope link  src 84.43.5.74  metric 1 
169.254.0.0/16 dev eth0  scope link  metric 1000 
default via 84.43.5.71 dev eth0  proto static 

(IP addresses not real)

All settings have been checked and double-checked with the ISP.

I don't know what else to try. The PCs themselves have various networking chipsets / different hardware configurations / different software.

Could it be the Media Converter that is malfunctioning? (I'm thinking the signal coming from that Media Converter is not strong-enough). In case the Media Converter is malfunctioning, how can I do measurements?

Can I blame the ISP or is my hardware to blame?

PS: I'm a software developer, so you can talk dirty, but please help me as this is way over my head.

SOLVED: This problem was from my ISP, trouble is they wouldn't admit it blaming it on the computers configuration. Heck, they wouldn't even tell me what the problem was.

I marked Bart's answer as being the answer as he gave pretty good advice.

share|improve this question
    
If you take the 3 machines off the network that work, do the other 3 start to work? –  gravyface Oct 20 '10 at 12:21
    
@grayface ... NO, I tried with a direct link (without the switch) ... all computers behave the same (3 working, 3 not working) –  Alexandru Nedelcu Oct 20 '10 at 12:26
    
What's your subnet mask of the IP address(es) that your ISP gave you? –  gravyface Oct 20 '10 at 13:23
    
Are you connecting all six machines directly to the outside network (public IP's)? If so, unless you have an actual reason to do it that way, get a router and NAT them. Otherwise you're exposing them to more traffic and potential script scanning than you need...or want... –  Bart Silverstrim Oct 20 '10 at 13:29
    
@Bart ... you're right, I should NAT them. I'll solve this after I fix the issue, which is one of those computers is a live server used by people. –  Alexandru Nedelcu Oct 20 '10 at 14:44

2 Answers 2

up vote 3 down vote accepted

Are you using NAT inside your network? I.e., a router behind which your systems are set up, so from the Internet your systems look like they're coming from one ISP-assigned IP connection? Unless you have a particular need otherwise, that's the way it normally is done (and you wouldn't need to necessarily hide the IP's since hundreds of thousands of people have 192.168.x.x addresses inside the network. It doesn't matter.)

You said you had a static configuration. Make sure your netmask is properly set on each machine, and that your IP addresses are all in that range.

Can your non-working machines ping each other, or the working machines?

Are there activity lights on the network cards? Are they lit? Does the switch show the connection ports lit?

share|improve this answer
    
+1 for NAT and a proper firewall: you really don't want those machines on the outside. –  gravyface Oct 20 '10 at 13:24
    
True, you're right ... it needs a NAT. But right now a server is down, and customers are calling. –  Alexandru Nedelcu Oct 20 '10 at 14:43
    
Customers are from Internet-side? Are you serving the same service on multiple IP's? If not, NAT it behind a router and forward the port. One possibility is that your provider isn't routing (or is blocking) the public IP's, have you worked with the upstream provider? –  Bart Silverstrim Oct 20 '10 at 15:25
    
Since you're talking about public IP's, you need to probably work with your provider to make sure they didn't change the routing table, firewalls, your allocation of IP's, etc... –  Bart Silverstrim Oct 20 '10 at 15:26
    
You can also check this by taking one of the working systems offline, and using their IP configuration on one of the "non working" systems to see if, when configured as a working system, they suddenly work. If not, reset the configuration back and see if changing ports on your switch makes a difference. –  Bart Silverstrim Oct 20 '10 at 15:27

Are there any anti-virus programs running? I know with ours, because of the new settings we have applied through McAfee, I have to disable it to go to the internet the first time, then once the connection is made, I can re-enable it, and all is well. Just a thought.

share|improve this answer
    
But one of his systems is Linux-based that isn't connecting. –  Bart Silverstrim Oct 20 '10 at 12:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.