Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm actually trying to set up a basic Tomcat cluster, as indicated in the official documentation. Here is my server.xml on the first server (Host section).

<Host name="localhost"  appBase="webapps"
        unpackWARs="true" autoDeploy="true"
        xmlValidation="false" xmlNamespaceAware="false">

    <Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster">
            <Receiver className="org.apache.catalina.cluster.tcp.ReplicationListener" tcpListenAddress="127.0.1.1" port="9015" selectorTimeout="100" maxThreads="2"/>
    </Cluster>
  <Valve className="org.apache.catalina.valves.RequestDumperValve"/>

However, catalina.out raises me the following error while starting. "WARNING: No rules found matching 'Server/Service/Engine/Host/Cluster/Receiver'."

If i try to define the Receiver's IP listen address like this :

  <Cluster className="org.apache.catalina.ha.tcp.SimpleTcpCluster" receiver.tcpListenAddress="127.0.0.1"/>

Catalina.out raises me the following error while starting:

WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Cluster} Setting property 'receiver.tcpListenAddress' to '127.0.0.1' did not find a matching property.

It's like Tomcat can't recognize the markup and it's properties... I have catalina-cluter.jar well present in my /usr/share/tomcat/lib directory.

pastebin link to my whole catalina.out output (cutted before webapp deployements/errors/warnings)

http://pastebin.com/75qhLkfJ

share|improve this question
    
The first config should work for the Cluster. It's a warning by the Tomcat logger, but the config works. –  JoseK Oct 21 '10 at 6:33
    
yes, it seems to work, but I would like to modify some configuration options like the tcpListenAddress (without having to modify my hosts file), to shape my cluster. –  Bacon Oct 22 '10 at 8:34
    
Ok, I've got it. Since tomcat 6.0 it seems that you have to explicitely declare memberships, receivers, senders and interceptor inside the Channel markup. Otherwise they won't be recognized. –  Bacon Oct 25 '10 at 11:31
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.