Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have several websites running in Sharepoint, with the following urls:

http:// svsp1:2000
http:// svsp1:2001 http:// svsp1:2002

(SVSP1 being the server's name, and the respective ports)

And now I need to test some of them using a real Blackberry, so i've set up a wifi router on the internal network to connect the blackberry.

The issue I'm having is that from the router I cannot ping svsp1, but I'm able to ping svsp1.domain.local (domain.local being the ad's name on the network), but that's not a solution because when I access the url with this full name, sharepoint does not recognize it.

More info regarding the internal infrastructure:

Server: Windows Server 2003 R2 and Sharepoint 2007 Router: Cisco Linksys WRT120N Cell: Blackberry Curve 8520

I tried first testing from the blackberry tool (search DNS), but it was giving an error. Then I tried pinging the server from the router admin page (Diagnostics), just to isolate the problem, and it cannot resolve.

SOLUTION

Set the field "Domain Name" to match the local network domain (here was company.local), and then it will start suffixing it to the requests.

WORKAROUND

I managed to workaround by changing the public URL for the websites from http:// svsp1:2001 to http:// svsp1.company.local:2001 . As we call here in Brazil, it's a POG.

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It sounds to me like the router and the Blackberries can't perform single label DNS queries, probably because they can't append the internal DNS suffix to the queries. Does the router have a FQDN or a DNs suffix that matches your internal DNS suffix? If not, setting the router's FQDN (if possible) to match the internal DNS suffix may solve the problem. Doing the same for the Blackberries (if possible) should solve their problem as well.

share|improve this answer
    
Thanks for the response, just for the record, on Linksys, we just needed to put the domain (domain.local) on "Domain Name" field, and then it started working. –  Daniel Tiziani Oct 20 '10 at 18:07
    
Glad to help... –  joeqwerty Oct 20 '10 at 18:30

I would tackle it as a "Sharepoint won't use FQDN" problem, and maybe then as a DNS devolution problem, depending on what the DNS server is. Remember that IE may do some sleight-of-hand with single-label URIs that other browsers like the Blackberry may not. For example, IE treats single-label names as being in the Intranet Security Zone, and is more permissive with scripting, etc. for those sites.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.