Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a server running on Ubuntu 8.04 LTS.

This version provides openssh 4.7.

I need to have a chroot environment for sftp.

I read chroot was possible with at least openssh 4.9.

So, how do I update easily to a newer version of openssh?

I specify its a remote server. So i can take the risk to damage the ssh server.

share|improve this question

3 Answers 3

The quick answer to this is: Upgrade to a newer version of Ubuntu. According to the online Ubuntu packages database, the version of openssh-server you need is in the Jaunty and later releases.

share|improve this answer
    
Is it possible to just upgrade openssh without upgrading the distrib? –  Arkan Oct 21 '10 at 3:50
    
Yes, it is possible to do this by adding an entry to /etc/apt/sources.list for an Ubuntu repository that contains the desired version of openssh-server. –  Steven Monday Oct 21 '10 at 4:56
    
Thanks for your answers. I'm gonna try this. Keep you in touch –  Arkan Oct 26 '10 at 16:13
    
Excuse me, what is the repository to add to sources.list to enable a 5.x openssh version ? I'm a little bit confused :? –  Arkan Oct 26 '10 at 16:34

I believe this page http://www.minstrel.org.uk/papers/ describes a process for old versions of OpenSSH. This other site http://www.linuxjournal.com/content/creating-chroot-sftp-jails-jailkit describes another approach.

Google is your friend!

share|improve this answer

I use MySecureShell on my Ubuntu Hardy servers to provide that same functionality.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.