Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am running RHEL 5.5. I edited my rc.local file, but I made a bad change because now when I try to boot RHEL, I get to my normal background but the login prompt does not appear now. Is there a way I can kick off the login screen manually or boot without kicking off rc.local?

I tried booting in single user mode, that didn't help either.

Just for FYI (i'm a linux newb in case you couldnt tell), i tried adding a shell script to my startup process via rc.local. As a result, I ran into this issue...

Thank you in advance for your help!

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You could try to edit your kernel options in grub to append:

init=/bin/bash

Failing that, you could try a rescue disk to fix your rc.local.

share|improve this answer
    
Thank you for the reply. the init option didnt work. Hoewver the rescue did: 1.) Boot from rescue CD or install DVD >> 2.) Run sosreport (for linux 5 users) >> 3.) In doing so, creates the rc.local in the sosreport >> 4.) Edited rc.local (etc directory) >> Rebooted under normal, machine booted fine. –  GavinWoods Oct 25 '10 at 13:36

At one point in the text boot process (press Esc if you get the graphical bootup instead) it will ask you to press I for interactive boot. Do so, then answer yes to every service other than local scripts.

share|improve this answer
    
Thank you for the reply, unfortunately this didn't work, it still booted rc.local. –  GavinWoods Oct 25 '10 at 13:35
    
Then you should report it as a bug upstream, since it should work. –  Ignacio Vazquez-Abrams Oct 25 '10 at 16:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.