Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Ubuntu on a box and have X2GO installed which is working great except copy and paste.

the client is a windows machine (tried 2 windows machines just in case)

everything is up to date.

sound works, things are nice and snappy and I am loving X2GO but no copy and paste is driving me nuts.

I tried NX and copy and paste works (but not sound).

any ideas?


share|improve this question
up vote 2 down vote accepted

The only way I've gotten copy and paste to work is to revert to the last "stable" version of the Windows X2Go client, the newer version is much nicer when doing multiple sessions and with sound, but like you've stated, not having copy and paste is a killer.

share|improve this answer
Yeah I found the latest beta/development release and it works. copy and paste and sound as well all work. though it is buggy as heck (well all of x2go is) I hope he keeps working on it and works out some of the bugs as it has a ton of potential. – Luma Mar 8 '11 at 5:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.