Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On Ubuntu 10.04, I have a USB 3G dongle which presents itself initially as a USB Mass Storage device with Windows drivers. usb_modeswitch can be used to get it to present itself as a modem, but the mass storage device still auto-mounts itself every time I plug it in as well. This is just an irritation/ugliness, not a serious problem, but I'm wondering if it's possible to write a udev rule to stop the device mounting, by filesystem name/UUID? I searched around, but couldn't find an example of such a rule.

share|improve this question
well, I have used usb_modeswitch for exactly that. A yum info usb_modeswitch tells me: "USB Modeswitch brings up your datacard into operational mode. When plugged in they identify themselves as cdrom and present some non-Linux compatible installation files. This tool deactivates this cdrom-devices and enables the real communication device. It supports most devices built and sold by Huawei, T-Mobile, Vodafone, Option, ZTE, Novatel." I do not use it any more because my laptop has an integrated sim, but it worked fine for me in the past. So maybe it has to be properly set? – natxo asenjo Oct 21 '10 at 19:29
So I am using usb_modeswitch (correctly, AFAIK), but I still see the USB mass storage mounted also. Am I doing something wrong? – Andrew Ferrier Oct 25 '10 at 9:34
apparently the udev rules in your system do not recognize your usb moudem. So you should file a bug against your linux distributor and ask them to fix it. Sorry I cannot help you any further. – natxo asenjo Oct 29 '10 at 7:41
@AndrewFerrier, Are you still looking for solution? – Sneetsher Jun 2 '15 at 21:02

I got it working by installing the usb-modeswitch package, and disabling autorun/automount in gconf-editor.

If that doesn't work, the only other (very inconvenient) way I saw was to boot with the modem plugged in; it worked then.... Good luck!

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.