Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First, this is strange. I have two laptops running Ubuntu 10.10. On one of them, when connecting my 3G modem, it just works out of the box. For the other one, I need to modprobe option to register it as a GSM modem.

How can I do this at boot?

share|improve this question
add comment

1 Answer

Add a line to /etc/modules that just reads "option".

share|improve this answer
1  
Note this might not work if the hardware is not present on boot and you might have to still run your modprobe option if you insert the card after boot. –  Caleb Oct 21 '10 at 22:06
    
Thanks! But what can I do to ensure it to be automatically recognized if inserted after booting? On my second laptop it works perfectly well without explicit modprobe. –  Johan Oct 22 '10 at 17:32
    
Before I speculate, can you verify that that doing this still does NOT work when inserting the modem later? Like I said, it MIGHT work. It's not clear what's wrong with your bus/hotswap/notification/detection systems, but it might be that having the module loaded ahead of time does the job when the devices shows up. –  Caleb Oct 22 '10 at 18:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.