Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a VSphere server and increased the drive for the C:\ drive on one of the VMs from 20GB to 30GB. Disk management shows the correct new size in the Disk view, but the volume information still shows 20GB as does the Local Disk (C:) Properties. We have re-scanned and refreshed several times and even rebooted the VM. Anyone have any ideas?

Server Manager and Local Disk Properties Image

share|improve this question
    
Have you run a chkdsk? –  jscott Oct 22 '10 at 18:45
    
+1 one for screen shot –  Gopoi Oct 22 '10 at 19:06
    
@jscott No, we would have to restart it again for that. –  Leigh Riffel Oct 22 '10 at 20:57
add comment

3 Answers

up vote 1 down vote accepted

I had this happen once when my Server 2003 disk resize with gparted bombed out in the middle. My fix was to add just another bit of space (1GB in my case) and then resize it; it saw the additional space once I did so.

share|improve this answer
    
+1 That worked! Adding 1 GB more in the same way did the trick. –  Leigh Riffel Oct 22 '10 at 20:56
add comment

I've seen this happen before, only it wasn't on a VM it was on physical hardware with storage based in a SAN after we extended a LUN. It fixed itself over the course of a day, and possibly a reboot. I can't say why it fixed, but it did self-rectify.

share|improve this answer
add comment

If it wasn't the C: drive, you could do an "extend" using Diskpart. A workaround:

1) Shutdown the VM.
2) Make a backup of the VMDK files for the disk you wish to extend (just in case)
3) Temporarily mount the VM's C: drive on another VM (e.g.: making it the D: drive of a gash vm).
4) Boot the temp VM.
5) From a command line:

diskpart.exe
list disk
select disk <disknum>
extend

Then shutdown and boot up the original vm.

share|improve this answer
    
Actually, scratch that - just noticed your volume is showing as 30GB. Interesting. How did you extend it? I'll leave the gumph above in, just in case it helps anyone else. –  Simon Catlin Oct 22 '10 at 18:57
    
Our SA did it. I'm not sure how. It has always worked in the past. –  Leigh Riffel Oct 22 '10 at 20:40
    
He re-sized the VMDK and then re-sized the c partition. –  Leigh Riffel Oct 22 '10 at 20:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.