Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been trying to set up roaming profiles and folder redirection, but have hit a bit of a snag with the latter. This is exactly what I've done so far:

(I have OU permissions and GPO permissions over my division's OU.)

  1. Created a group called Roaming-Users in the OU 'Groups'
  2. Added a single user (testuser) to the group
  3. Using the Group Policy Management tool (via RSAT on Windows 7) I right-clicked on the Groups OU and selected 'Create a GPO in this domain, and Link it here'
  4. Added my 'Roaming-Users' group to the Security Filtering section of the policy.
  5. Added the Folder Redirection option, specifically for Documents. It is set to redirect to: \myserver\Homes$\%USERNAME%\Documents (Homes$ exists and is sharing-enabled).
  6. Right-clicked on the policy under the Groups OU and checked Enforced.
  7. Logged into a machine as testuser successfully. Created a simple text file, saved some gibberish, logged off.
  8. Remoted into the server with Homes$ on it, noticed that the directory Homes$\testuser was created, but was empty. No text file to be found.

From what I've read, I did everything I aught to...but I can't quite figure out the issue. I had no errors when I logged off about syncing issues (offline files is enabled) or anything, so I can only imagine my file should have ended up up on the share.

Any ideas?

EDIT: Using gpresult /R, I confirmed the user is in fact part of the Roaming-Users group, but does not have the policy applied, if that helps.

EDIT 2: Apparently you can't apply GPOs to groups...so I applied to users and used the same security filter to limit it to my test user. Nothing happens as far as redirection goes, but I now have the following error in the event log:

Folder redirection policy application has been delayed until the next logon because the group policy logon optimization is in effect
share|improve this question
3  
As you stated in your second edit, Group Policy cannot be applied to groups in the sense that you can't link it to the OU where the groups are. You need to link it to the OU where the users are then you "apply" it to specific users by using the group in your Security Filtering. –  joeqwerty Oct 22 '10 at 23:54
add comment

1 Answer

Windows is going to try to create a folder named My Documents (it is after all My Documents redirection) in the %username%\Documents folder but the %username% folder and the Documents folder don't exist, so Windows can only create the %username% folder. If the %username% folder and the Documents folder actually existed Windows would create the folder as:

\\myserver\Home$\username\Documents\My Documents.

What you're trying to do is to have Windows use a folder named Documents for the My Documents folder, which isn't possible. My Documents is a "system object", if you will, and Windows is not going to substitute your Documents folder for the My Documents system object.

Try setting a path like this \\myserver\Home$ to have Windows create the folder as:

\\myserver\Home$\username\My Documents

or some other combination that suits your folder structure that allows Windows to create the My Documents folder for each user or to create both the %username% and the My Documents folders.

share|improve this answer
    
Sorry - what I meant to say is that it is set to redirect to \\myserver\Homes$. I just stated the full name that GPM shows you in the editor to show that it was aiming at the right location. In reality, I typed \\myserver\Homes$ into the box. –  user57999 Oct 22 '10 at 23:47
    
OK, now I get it. Also, my answer is applicable when the Folder Redirection policy is set to "Create a folder for each user under the root path", which is how I assumed you had it configured. –  joeqwerty Oct 22 '10 at 23:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.