Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm about to throw in the towel on this one.

Running SQL Server 2008 enterprise on Windows 7 x64. Can't get past this issue.

When I try to Import / Export Data from databases through SQL Server Management Studio I get the following Error.

Error:

TITLE: SQL Server Import and Export Wizard
------------------------------

The SSIS Data Flow Task could not be created. Verify that DTSPipeline.dll is available and registered. The wizard cannot continue and it will terminate.

------------------------------
ADDITIONAL INFORMATION:

Cannot create a task with the name "STOCK:PipelineTask". Verify that the name is correct.
 ({0194F10C-9860-4A4F-AF8B-DE7EFD89859F})

I have tried many solutions found via Google, but none of them have worked.

A side issue that may be related is when I try to create an Integration Services Project in Business Intelligence Studio I get a 'project creation failed' error.

share|improve this question

put on hold as off-topic by kce, Ward, mdpc, longneck, HopelessN00b yesterday

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – kce, Ward, mdpc, longneck, HopelessN00b
If this question can be reworded to fit the rules in the help center, please edit the question.

    
You might be running into a conflict with Visual Studio here. Do you have that installed? –  user3914 Nov 4 '10 at 19:21
add comment

1 Answer

This worked for me.

Not from me but this guy/place.

user: KirkHaselden

http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/ec0dd504-b27a-4895-beb0-25a883b91430/

Hmmm, very odd. It sounds as though you have a corrupted installation. Is this the first time you've installed SQL Server on that machine, IOW is it a clean install? You might try to regsvr32 DTSPipeline.dll. Then try again. It appears that it's just not registered.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.