Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm having trouble with installing Wordpress on a dedicated Microsoft Windows Web Server 2008 R2.

I've installed Wordpress Version 2.9.2 from Web platform installer 3.0.

After installation when I try to access wordpress, either from ~/index.php or ~/wp-admin/install.php I get the error:

HTTP Error 500.0 - Internal Server Error File monitoring is enabled for a file which could not be found

Modul: FastCgiModule
Notification: ExecuteRequestHandler
Handler: PHP52_via_FastCGI
Error Code: 0x80070003

I have both .Net 2.0 and .Net 4.0 installed.

Adding a "phpinfo.php" gives me the same error.

The application pool in IIS7 that's used for the website is: "No Managed Code" and set to "Integrated" in "Managed Pipeline Mode".

I've tried to reboot the machine.

What's more can I try?

share|improve this question
    
I also have this problem. How have you solved this? Please give me more details, I haven't installed Wordpress form web platform installer, but copierd it from old website and updated wp-config.php, plus I have imported old db to the new server. –  Piotr Wach Jun 22 '11 at 20:55
1  
@Piotr - you can see that the OP has said I solved it by removeing the web app created by web platform installer and creating a new. –  Mark Henderson Jun 23 '11 at 4:07

5 Answers 5

I solved it by removeing the web app created by web platform installer and creating a new.

share|improve this answer

I solved the same issue setting the Enable 32bit Applications option in the Advanced Settings of the application pool to true.

share|improve this answer
    
I just solved this issue, I installed everything as suggested within Microsoft's site. I came here and found splattne answer and it worked! Just make sure the application pool you are enabling the 32bit Applications is the one your Wordpress is using. –  Ryan.Marinoff Dec 30 '13 at 6:45

After reading splattne's answer I had a look at my application pools and realized that I had 2. The one I originally created and also the one created by Web Platform Installer (probably caused by an earlier attempt to fix issues with Web Deploy).

To solve this,

  • I switched the site's application pool to "DefaultAppPool"
  • Removed both application pools
  • Created a new .Net 4.0 / Integrated Application Pool
  • Changed to allow 32bit in Advanced Settings
  • Ensured the web site's permissions included "Modify" for "IIS AppPool\Wordpress_Site_AppPool_Name_Here"
share|improve this answer

I solved this issue by adding permissions to the PHP folder. It seems the Web Installer doesn't do this by default. In my case I need to add Read&Execute, Read, and List folder contents permissions to the NETWORK SERVICE user group.

If you already have another working copy of PHP installed on your server you can simply duplicate its permissions by looking at it in Properties->Security.

share|improve this answer

I also had a similar issue after installing Web Deploy. For me, it turned out that I previously installed and subsequently uninstalled the PHP 5.4 handler, after downgrading to PHP 5.3. While the PHP 5.3 version works nicely for me, the 5.4 handler mapping lingered. I guess this never came to the forefront, because for some reason the 5.3 handler mapping was chosen for *.php files. After I deleted the 5.4 handler mapping (leaving only the 5.3 handler mapping), the problem went away.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.