Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed VSFTP on my Ubuntu 10.04 server and haven't configured much else on it. I have an SSH user called "tom" which when I log into the FTP and try and create a file as this user, or any other for that matter, the default permissions of the file are 600 which is annoying as the web server can't read them...

Does anybody have any idea how to fix this?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Change your local_umask to the default 022 on your vsftpd.conf, alternatively you can enable suexec on your apache server which will allow you to read files with that user/groups permission without others.

Resulting in: local_umask=022

If you want to change the for anonymous users as well, the option directive is anon_umask with the same umask as above.

share|improve this answer
    
This works a treat! Thanks :D –  user58059 Oct 24 '10 at 0:21
    
you welcome ;) ! –  Prix Oct 24 '10 at 1:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.