Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to copy and paste between my desktop a remote desktop session even though Clipboard is enable under local resources in the Mstsc.exe

I'm on a Windows XP SP3 connected to Server 2003.

share|improve this question
    
Can you copy and paste AT ALL, or does it stop working after 30 minutes or so? –  Mark Henderson Oct 25 '10 at 6:52
add comment

2 Answers 2

up vote 3 down vote accepted

When you run mstsc.exe (the client), go into options and go to the Local Resources tab. Ensure "Clipboard" is selected in the "Local devices and resources" group.

If you have a pre-defined .rpd file, right click to edit and get the options, then ensure you save the file to persist any updates.

Also check that clipboard integration is not disabled on the server. I'm not sure that a normal user can check this, but with suitable rights it is easy. On the server in Remote Desktop Session Host Configuration (or Terminal Services ... on older Windows versions) select properties for the connection and the Client Settings tab allows various client integration functions to be disabled (checking the checkbox disables the feature).

EDIT: Thanks to @Sergy for reminding me that clipboard integration can also be disabled on the server.

share|improve this answer
    
That sure is selected and Im not running it from a .rdp shortcut. –  Jake Oct 25 '10 at 8:40
2  
Clipboard redirection can be disabled in terminal server configuration (it will override user settings). –  Sergey Oct 25 '10 at 9:47
    
@Sergey: good point, time to update the A. –  Richard Oct 26 '10 at 8:40
    
@Sergey - How can I know (as user - not as admin) if Clipboard redirection is disabled ? –  itsho Jun 10 at 10:32
add comment

If copy paste is enabled both in the server and the remote desktop connection but still doesn't work, the following works for me (taken from here):

Do the following on the remote machine:

  1. Load up task manager (right click taskbar and select Task Manager)
  2. Go to the Processes Tab
  3. Select rdpclip.exe
  4. Click End Process
  5. Go to the Application Tab
  6. Click New Process
  7. Type rdpclip
  8. Click Ok
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.