Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to open Port 1433 on windows firewall but not having much luck.

I've added a new Inbound Rule (attempting to open TCP 1433) which looks okay and appears to be on but when I run netstat -an the server doesn't appear to be listening on Port 1433.

I've gone through the motions of setting SQL Server Express to not use dynamic ports (I looked down the list of IPs in the config manager and enabled the servers external IP, removed "0" from dynamic ports and added 1433).

I feel that this is an issue with the firewalling and wondered if anyone had any pointers on where I may be going wrong.

Many thanks,

Andrew

share|improve this question

3 Answers 3

You should leave blank 'TCP dynamic port' field and add 1433 to 'TCP Port' field to disable dynamic port allocation for SQL Server Express instance.

Have you restarted SQL Server express after your configuration changes?

share|improve this answer
    
Hi, I've just checked my TCP/IP Properties and for "IP2" I had set Dynamic Ports to blank and 1433 in TCP Port. Am I meant to do this for all the IP's in the list or just the external ip? I've got IP1-IP8 then an IPALL option –  Andrew Duncan Oct 25 '10 at 10:19
    
Yes - I did restart SQL Express after making changes. –  Andrew Duncan Oct 25 '10 at 10:20
up vote 1 down vote accepted

In response to my own question I have figured it out (with the help of Sergey).

It turns out that SQL Server 2008 Express needs to be configured correctly in addition to windows firewall before the server will start listening on Port 1433.

I was able to resolve my issue by:

  1. Opening SQL Server Configuration Mangager
  2. Going to the Network Configuration for SQLEXPRESS
  3. Editing "IPALL" of TCP/IP Protocol.
  4. Setting the values of the options to the values highlighted by Sergey above.

Turns out the issue I was having was editing the incorrect IP in this properties window. I was attempting to edit just the external IP - it seems I was mistaken in doing this.

Hope this solution helps others with similar problems.

P.S. Don't forget to add the incoming rule to your windows firewall.

Troubleshoot: If none of them works, try to add the .exe file named: sqlbrowser. usually nested in: %ProgramFiles%\Microsoft SQL Server(SQL version number)\Shared\SQLBrowser.exe (OY)

share|improve this answer
    
Thanks a lot. Finally solved my problems after 2 hours of doing what should be very simple. –  Gluip Apr 18 '12 at 9:42

I am trying to open port 25 after setting an imbound rule and even turning off the firewall. No luck opening that port yet.

share|improve this answer
    
Post this as a new question, and include some more details. Don't write this as an "answer" to an old question. –  mfinni Feb 9 '12 at 16:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.