Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Snow Leopard 10.6.4 mac ports 1.9.1

I have just installed macports and I want to install git-core.

However, I get the following errors:

--->  Computing dependencies for git-core
--->  Dependencies to be installed: python26 db46 gdbm readline sqlite3 rsync popt
--->  Building db46
Error: Target returned: shell command failed
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log
Error: The following dependencies failed to build: python26 db46 gdbm readline sqlite3 rsync popt
Error: Status 1 encountered during processing.
To report a bug, see <>

I have tried doing a port selfupdate and a port clean all and then trying to install again. But still get the same problem.

I have also tried install the dependent db46 on its own.

Here is the log message:

:error:build Target returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for db46): org.macports.activate org.macports.destroot org.macports.install

This is my first time using mac ports.

Many thanks for any suggestions.

share|improve this question
My configuration (OS version, macports version) is identical to yours. I just did sudo port clean all; ports selfupdate; ports install git-core and the installation completed with no issues. One difference I noticed between your install attempt and mine is that your list of dependencies is much smaller. For example, I had to install perl5, while this package is missing from your list. Do you also happen to have fink installed in parallel? – nayden Oct 25 '10 at 12:32
@Nayden. I don't have Fink. I only just installed macports today. thanks – ant2009 Oct 25 '10 at 13:04
Very strange since our configuration is identical. If someone doesn't come up with a good answer to your issue if I were you, I would reinstall macports and give it another chance. Good luck. – nayden Oct 25 '10 at 14:06
Try adding -d for debug output to the install command and let us know the result. Maybe it will show something useful that it didn't before. "sudo port -d install git-core" – Xhantar Oct 29 '10 at 19:51
It's not MacPorts, but there is a Google Projects page providing installable packages. I use it on my box instead of compiling from source. Looks like it's the same version as in MacPorts. – Tim Bielawa Oct 31 '10 at 23:52
up vote 2 down vote accepted

I would suggest using Brew.

Brew install git

share|improve this answer

problem is that 10.6.4 update destroys some symlinks to libraries that db46 needs.. they're still there just no longer in the expected place.. easiest fix is to demote your xcode to lower version and reinstall. grab your snow install disk and reinstall xcode.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.