Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In our company, we have a 32 bit Windows 2008 print server. I have successfully installed many printers with both 32 bit and 64 bit drivers. We have two Xerox Wide Format printers and I cannot install the 64 bit drivers. I believe it's because they are not digitally signed. I can install the 32 bit drivers on the server and it comes up with the red security warning that they are not signed, but I installed them anyway. When I go to my Windows 7 64 bit machine to install the drivers, I get the message:

"Unable to install Xerox 6050A PS Wide Format with FreeFlow Accxes, x64, Type 3 - User Mode driver. Operation could not be completed (error 0x00000002)."

I did some searching and I think it's because the drivers are not signed. How would I get passed this problem? Is there a way I can manually install the drivers on the server?

On a side note for anyone thinking about buying a Xerox product: I don't know why a company as large as Xerox would not sign their drivers. I tried to contact Xerox technical support, but I can't get passed their 1st level support because I do not have a contract with them. I was refused support unless I wanted to pay for 2nd level support.

share|improve this question
What happens when you install the driver locally on the Win7 machine rather than from the printer share? – Bart Silverstrim Oct 26 '10 at 14:26
I have the Red warning message about the driver not being signed, but I can click Install Anyway and it will install locally on the Win7 machine. I know I can install the printer locally on every machine, but we want it administered through a print server. – awilinsk Oct 26 '10 at 14:41
up vote 1 down vote accepted

Yes they need to be signed.

There are ways to disable the signature enforcement but you would need to do this on every 64bit win 7 machine requiring them, it isn't straight forward and has drawbacks.

So you can do that, pester Xerox for signed drivers or don't use 64bit Win 7

share|improve this answer
I'm not having that problem yet. I can't even install the the 64 bit drivers on the print server. I've tried to talk to Xerox and they're impossible. They keep saying "you do not have a contract with us" I've went through two managers, but keep getting the same response. Their tech support sucks. – awilinsk Oct 26 '10 at 14:59
well to be fair when you bought the printer it was for a given OS, they arn't under any obligation to add support for a new one. – JamesRyan Oct 26 '10 at 15:20
Have you done this?… – JamesRyan Oct 26 '10 at 15:21
I have checked the inf files and the names match for the 32 bit and 64 bit. – awilinsk Oct 26 '10 at 17:37
the installing it remotely part? – JamesRyan Oct 27 '10 at 14:42

I would advise that you attempt to sign the unsigned package, to do this you have to open the Certificates MMC snap-in, the instructions are here.

Here are explicit instructions on what you need to do to sign the package.

After you've gone through this process, you should be able to appropriately install the additional architecture type you're having issues with.

In reference to the error that you're getting, please clarify if you have other Xerox devices installed (using other packages) or if you're using the Xerox Global Print Driver in any shape or form within your environment. In the meantime, see if you can remove all of this particular package's iterations within your environment and then attempt to install the unsigned package first.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.