Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an IIS 7, Windows Server 2008 R2 box with a relatively fresh install. I've deployed a .NET 2.0 application using windows autentication to the server, and from the default website, added it as an application. I updated the IIS authentication to enable Windows Authentication.

When I went to share out the physical directory for the application so that a developer could deploy updates, the users began to receive 401 errors. I can reliably recreate the issue by sharing out the directory of any newly created application. The IIS user has the necessary read/write access to the directory.

What do I need to do to keep web users from receiving 401's while at the same time allowing this developer to have access to the physical directory for deployments?

Thanks in advance!

share|improve this question
    
I would suspect that you have to be changing other permissions in addition to simply adding a share permission. Is the IIS home directory a literal location on the local machine, and not a network share? Are the permissions for the group IIS_IUSRS still intact and appropriate? When this problem occurs, try setting IIS_IUSRS to full permissions and see if it persists. –  PMGoldstein Oct 26 '10 at 15:49
    
If I am changing other permissions, it's completely inadvertent. My only steps where to right-click on the directory, share->specific users, add the developer, done. Though I'm not the server admin, I assume the storage is mounted EMC storage or similar, it's not a network share. Permissions for IIS_IUsrs still look correct but I'll go back and recheck. –  tonyellard Oct 26 '10 at 16:02
    
What do you mean by 'share'? Are you right-clicking on the folder and setting permissions, or using IIS Manager permissions, FTP settings, authorization, or something else? –  Scott Forsyth - MVP Nov 2 '10 at 13:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.