Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've been trying to get the OpenVPN client to install on a Windows 7 laptop, and so far none of the various versions work. Some won't install at all (one version's .exe installer humorously told me that "OpenVPN is not supported on Windows"), other have problems during or after installation with a library (libeay32.dll I think).

I know that there are people who've successfully gotten it working, but I'm out of ideas. The versions I've tried are 2.0.9, 2.2 beta 3, 2.1.3, and a couple others. I think 2.0.9 gets farthest, but "tapinstall.exe" doesn't work (and gives no explanation of what happened; it just prints a message that it failed).

share|improve this question

1 Answer 1

up vote 1 down vote accepted

OpenVPN 2.1.3 from OpenVPN.net installs and works fine.

share|improve this answer
    
I'm pretty sure that's one of the versions that gives me the errors about libeay32.dll. The errors come up in the installer, and then if I "Ignore" it the client fails as soon as it tries to connect. –  Pointy Oct 26 '10 at 21:23
    
Is the Windows-7 installation on your laptop a "clean" one (format + reinstall, then install OpenVPN) or not? Could this be an indication of further problems with your Windows-7 system? –  adamo Oct 26 '10 at 21:33
    
I think the Windows 7 installation's about as good as it can be. The DLL problem I've found was just a result of the installer failing to stop an old version of the OpenVPN GUI. Once I killed that, install works, but I still can't get it to add more adapters, and the one the installer creates can connect to a VPN but then not do anything. I tend to become enraged whenever I come in contact with Windows anyway; it was a whim project. Thanks for your help! –  Pointy Oct 26 '10 at 21:47
    
I uninstall previous versions of OpenVPN before installing a newer one. As to the adapter not passing any traffic though, maybe this is a configuration problem? If your config file contains a "dev tun0" try changing it to "dev tun". –  adamo Oct 27 '10 at 5:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.