Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm pulling my hair out figuring this out. My startup-config is good, I can view it with a show command. I'm trying to copy it to a tftp server:

asa5505# copy startup-config tftp

Address or name of remote host []? ipaddress

Destination filename [startup-config]? t
%Error writing tftp://ipaddress/t (Timed out attempting to connect)

On my TFTP server (SolarWinds), I get the following:

binary, PUT. Started file name: C:\TFTP-Root\t
binary, PUT. File Exists, C:\TFTP-Root\t
binary, PUT. Deleting Existing File.
binary, PUT. Interrupted by client, cause: The process cannot access the file 'C:\TFTP-Root\t' because it is being used by another process

I've used tftpd32 with same results. I've tried different servers, even one on the same network as the asa ... same results. It'll create a 0 byte file and never do the dump. What's going on? Everything is working normally except for this.

share|improve this question
What happens when you try to copy a file to/from from a non-Cisco TFTP client? – user48838 Oct 26 '10 at 21:42
It works fine when I use any other client. – Geoffrey Oct 26 '10 at 22:15
Are the "test" clients and the Cisco unit in the same network? – user48838 Oct 27 '10 at 1:53
Yep, both are on the same network. – Geoffrey Oct 27 '10 at 2:43
Then you might check the interface settings (maybe line, MTU, etc.) which is being utilized for the TFTP transfers on the Cisco. – user48838 Oct 27 '10 at 5:43

Looks like the answer is right in the question:

binary, PUT. Interrupted by client, cause: The process cannot access the file 'C:\TFTP-Root\t' because it is being used by another process

It's a problem with the TFTP server. Fix it there.

share|improve this answer
I think it's a problem with the path the cisco TFTP client is requesting to write to. Works from other TFTP clients . . . – Craig Constantine Nov 8 '11 at 18:32
If you delete the 't' file on the server first and then try the transfer again, what shows up in the log? – MikeyB Nov 8 '11 at 20:24

not experienced with Windows TFTP servers, but with tftpd-hpa on Debian and the built in TFTP server on Mac OS X, I found I had to create the file first, make it world writable and then push the tftp file from IOS.

Then it worked.

share|improve this answer

You may have to specify some or part of the TFTP-server-side path in your Cisco command. I haven't done this in a while. But I recall having a TFTP server that had rules that you could only write into a sub directory. So its TFTP dir was home'd in like /usr/tftp and writing was only permitted into /usr/tftp/incoming and, (this doesn't seem to be a problem in your case,) it only let you write onto existing files. So I had to 'touch' a file (eg, 'cisco.config' in my example here,) on the TFTP server first too. Then on the Cisco I had to say...

copy conf tftp
incoming/cisco.config my "answer" is: check that your specifying any relative path that the TFTP server expects. Other TFTP clients might be doing that behind the scenes for you . . .

share|improve this answer
Interesting I'm getting down voted for suggesting the problem might with the path he's specifying on the Cisco's TFTP command. OP states the TFTP server works from other TFTP clients. People are upvoting the answer that misses this aspect of OP's description? Curiouser and curiouser. – Craig Constantine Nov 8 '11 at 18:31

Did you delete


before TFTP copy ?

It looks that file is already exist and it's locked by other process, so TFTP can not rewrite it.

share|improve this answer

Have you tried the deprecated write net to copy to TFTP?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.