Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've upgraded to Snow Leopard, re-installed XCode, re-installed macports and when I try to install git I get:

:~ $ sudo port install git-core +svn
Error: Cannot install git-core for the arch(s) 'x86_64' because
Error: its dependency zlib is only installed for the arch 'i386'
Error: and the configured universal_archs 'i386 ppc' are not sufficient.
Error: Unable to execute port: architecture mismatch

Am I doing something wrong?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

My first answer: it looks like the issue is with zlib. I'm guessing you have an old (pre-Snow-Leopard) version of zlib installed; port is seeing that it's there (and therefore not installing a new version) but isn't seeing the right architecture to build a 64-bit Git. I'd uninstall and reinstall zlib within port first, then try git again.

My second answer is a cop-out: try installing Git from the installer instead. (That's what I was trying to do.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.