Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting the following error when trying to run any of the Maintenance Task jobs that had been created on the server:

Message 
[LOG] Step 1 of job 'Weekly Backup' (0x8EC76A988468C74897562440AADD067D) cannot be run because the SSIS subsystem failed to load.  The job has been suspended

The Maintenance task was originally set up months ago and ran fine about until this week. When checking the Sql Server Agent logs, I see the above error. I have tried restarting services, reboot (in case of file locks?), and I've also tried the advice from here: http://support.microsoft.com/?kbid=914171

use msdb
go
delete from msdb.dbo.syssubsystems
exec msdb.dbo.sp_verify_subsystems 1
go

And restarting SQL Agent.

Same problem continues and the job is marked as Suspended. Any ideas?

share|improve this question
    
You also need to restart SQL Server instance. –  Aamod Thakur Apr 16 '12 at 5:56

2 Answers 2

What changed on the server this week? Any permissions issues, patches, uninstalls, etc? Hotfixes / SP / Updates to SQL Server?

Here are a couple of thoughts:

  • Look in the SQL Server log files and the Windows Application and System event logs for messages that might give you more detail on what the specific problem is.
  • Make sure you see SQL Server Integration Services in your list of services and that it's running. (I'm assuming you're doing this when you're restarting services, though)
  • Run this query on your server: SELECT * FROM msdb.dbo.syssubsystems WHERE subsystem='SSIS' and make sure that you get a record back in the result set. If not, then you probably need to reinstall Integration Services on your server.
  • If you do get a record back from the query in the previous point, verify that the files exist in the paths in the subsystem_dll and agent_exe columns and that the permisions on the folders and files are good. If the files don't exist you'll probably need to reinstall Integration Services.
share|improve this answer
    
Thanks @squillman. Unfortunately I couldn't get a 100% definite answer on the cause and most likely re-installing SSIS will work. I suspect the timing of the issue around same time as a batch of windows updates / patches. +1 for the answer –  user01025443 Oct 29 '10 at 23:37

This can happen on a server with multiple instances and one of them has been upgraded. SQL 2005 and 2008 SSIS subsytems are not very compatable with each other and when you do a SQL 2008 in place upgrade it will upgrade SSIS, changing the path to DTExec and the required dlls.

share|improve this answer
    
Thanks @jason. See my answer to @squillman. +1 for the answer –  user01025443 Oct 29 '10 at 23:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.