Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm torturing myself with the task of trying to get an OpenVPN connection to a work subnet working under Windows 7. After some travail I've gotten the OpenVPN client to work and properly connect. However, though the connection is apparently up, Windows considers the network a "public network" and won't let me browse it. It tells me that I need to change the networks profile (or something) to "Home" or "Work". The problem is that I have no idea how to do that, and I see no obvious place in the Network control dialog(s) to do that.

I suspect this is really simple and obvious, but I've clicked through every link I can find in those control panel dialogs and nothing works. It feels kind-of like playing Myst.

share|improve this question
add comment

5 Answers

up vote 5 down vote accepted

According to one forum post you need to configure the gateway for that particular network.

http://www.tomshardware.com/forum/215-63-change-network-type

For Windows 7 network types, the secret lies in the GATEWAY entry. Any network you connect on that doesn't have a DEFAULT GATEWAY provided with, becomes PUBLIC and you cannot change it's type.

share|improve this answer
    
Yep that does it. So obvious (not). Thanks!! –  Pointy Oct 27 '10 at 22:53
add comment

In the end this seems to be an OpenVPN error. It looks like the way openvpn sets up the network interface on Windows-7, Windows forces it to be public. The network type can not be changed, no matter what group policy settings you change.

I fear OpenVPN will have to react on this topic, it's causing some applications to fault. For example EA was stupid enough to program Origin in a way that only checks for that network flag in windows to see if it is online. This means the service (used by millions) can't function through openVPN. I am sure more troubles exist.

share|improve this answer
add comment

If you are able to, add this to your OpenVPN server config:

push "route 0.0.0.0 0.0.0.0 vpn_gateway 999"

So that Windows 7 will permit setting the network type, it pushes a bogus default route, which should never be used (because of the high metric cost). If it's desirable to push only to Windows 7 hosts, try using OpenVPN client config.

share|improve this answer
    
OK, thanks! I haven't been in this situation in a while, but I'll keep this in mind. –  Pointy Jul 9 '13 at 12:53
add comment

Please make sure you are starting OVPN GUI as a Administrator (right click, Run as Administrator).

Usually OVPN server pushes a route command into a client. If you run OVPN GUI as a user (it does it by default) you will see you OVPN client connected but it will not be able communicate with the remote network because OVPN client was unable to modify your routing table.

I had this issue before. And initially I believed Windows is blocking the access because it treats OVPN network as a public network. But I was wrong. The only issue was missing route.

Please try to run OVPN GIU as administrator. My OVPN connection is marked as public network in Windows 7. And it works fine.

share|improve this answer
    
Thank you for this answer - it has been a while since I had to worry about this, but I'll definitely try to remember next time I do. –  Pointy Jan 20 '11 at 13:59
add comment

I have had the same problem. Here is a possible solution Start command line as a Administrator. Look at the settings from your openvpn adapter through ipconfig /all. Write down the ip number at the DHCP server. Goto the openvpn adapter properties ( make sure you do this as a administrator ) and add a gateway by using the ip number you have writen down from the DHCP server. Now you are able to change from Public to Work.

Regards,

Jan Pijl.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.