Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a MOSS 2007 environment, 2 web servers and a DB server, load balanced between the two web servers.

I deployed a web part recently, which worked fine for a while, but failed on web server 2 after a day. When it fails, it gets the error message:

'A Web Part or Web Form Control on this Page cannot be displayed or imported. The type could not be found or it is not registered as safe’

Once it has failed, it will stay that way until an IIS reset is done.

The other web server never fails, I tried to force the second web server to fail to recreate the issue and have been unable to do it. I tried placing it under heavy http traffic and it handled it fine. Put it back in the pool and it failed again after about 7 hours.

So, if i remove the .dll for the webpart from the affected web server, the webpart doesnt stop working. Is this normal behavior? I checked the bin directory for the site and the global assembly and it there is no other copy of the .dll anywhere else on the server.

Also, when checking the web part gallery, if the web part has failed it will appear in the gallery, but by trying to add a new webpart, the .dll wont be listed.

I have no idea how to continue troubleshooting from here or even fix it, any ideas?

share|improve this question

1 Answer 1

It appears the web part is not deployed to server 2 correctly. You can check this in Central Admin:

CA-Operations-Solution Management. Under Status, it will tell you whether or not it is deployed correctly aross the farm.

Now, as to why, thats a different matter. Something in the configuration of front end 2 is preventing the correct deployment/replication.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.