Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm confused. i've changed the transport limits in organisation configuration>global settings> transport settings. I've also altered it in the send and receive connectors max message size.

When i attach a file over 10mb in outlook it says attachment size exceeds the allowable limit.

i can't find where i'm supposed to change it. I'm sure it's easy...

share|improve this question

6 Answers 6

If you're running Exchage 2007 SP1 changes you made with Set-TransportConfig should have copied to the global settings in AD. If you're not running Exchange 2007 SP1, then you're going to need to change these values in AD using something like ADSIEDIT.

First, here's a good overview of the process w/ screenshots: http://exchangepedia.com/blog/2007/09/exchange-server-2007-setting-message-size.html

If you're still ing Exhcange 2007 RTM, here's an article that will describe changing the global size limit: http://technet.microsoft.com/en-us/library/bb310771.aspx

You're best off going to Exchange 2007 SP1 (or SP2) if you're still running RTM.

Edit:

Could you post a link to the output of a "Get-TransportConfig", "Get-SendConnector | fl", "Get-ADSiteLink | fl", and "Get-RoutingGroupConnector | fl" from the Exchange Management Shell?

share|improve this answer
    
i am on sp1 and have followed the instructions and set everything to 50mb but outlook still won't let me attach anything over 10mb. –  Charlie Bear Jun 5 '09 at 8:53
    
Hmm. What's the specific error you're getting back? It's likely there's still a limit set somewhere, but I'm drawing a blank at the present moment. –  Evan Anderson Jun 5 '09 at 12:35
    
outlook it says "attachment size exceeds the allowable limit". before i upgraded to 2007 i could send large files so it must be exchange's doing... –  Charlie Bear Jun 5 '09 at 15:31

Its the MaxSubmitMessageSize property that you need to change, in Exchange 2007 this is read from 3 places, in this order:

  • Individual Mailbox
  • Transport Settings container
  • Organisation Settings container

To change these use the following commands inside the Exchange Management Shell

Transport Container

This will set the value for all users, in this case to 50Mb

set-transportconfig -maxsendsize 50Mb

Individual Mailbox

 set-mailbox 'mailboxName' -maxsendsize 50Mb
share|improve this answer
    
Do remember that if you're running Exchange 2007 RTM the "Set-TransportConfig" applet won't set the organization setting. That's "fixed" in SP1. You'll have to use ADSIEDIT (or some other tool to manipulate arbitrary objects in the AD) for that in an Exchange 2007 RTM environment. –  Evan Anderson Jun 4 '09 at 13:45
    
Very true, thanks for pointing that out! –  Sam Jun 4 '09 at 14:04

Ok here are some outputs from the manangement shell. I have to put this here since it's too long for a comment...

Get-TransportConfig:

ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {127.0.0.1}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 50MB
MaxRecipientEnvelopeLimit      : 5000
MaxSendSize                    : 50MB
eceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True

Get-SendConnector | fl

AddressSpaces                : {smtp:*;1}
AuthenticationCredential     :
Comment                      :
ConnectedDomains             : {}
ConnectionInactivityTimeOut  : 00:10:00
DNSRoutingEnabled            : True
DomainSecureEnabled          : False
Enabled                      : True
ForceHELO                    : False
Fqdn                         : [our domain]
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : JUDGES
Identity                     : Windows SBS Internet Send JUDGES
IgnoreSTARTTLS               : False
IsScopedConnector            : False
IsSmtpConnector              : True
LinkedReceiveConnector       :
MaxMessageSize               : 50MB
Name                         : Windows SBS Internet Send JUDGES
Port                         : 25
ProtocolLoggingLevel         : None
RequireTLS                   : False
SmartHostAuthMechanism       : None
SmartHosts                   : {}
SmartHostsString             :
SourceIPAddress              : 0.0.0.0
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {JUDGES}
UseExternalDNSServersEnabled : False

Get-ADSiteLink | fl

Cost              : 100
ADCost            : 100
ExchangeCost      :
MaxMessageSize    : unlimited
Sites             : {Default-First-Site-Name}
AdminDisplayName  :
ExchangeVersion   : 0.0 (6.5.6500.0)
Name              : DEFAULTIPSITELINK
DistinguishedName : CN=DEFAULTIPSITELINK,CN=IP,CN=Inter-Site Transports,CN=Site
                s,CN=Configuration,DC=contra,DC=local
Identity          : contra.local/Configuration/Sites/Inter-Site Transports/IP/D
                EFAULTIPSITELINK
Guid              : ca9984b7-5541-471b-9914-be56515bef87
ObjectCategory    : contra.local/Configuration/Schema/Site-Link
ObjectClass       : {top, siteLink}
WhenChanged       : 18/12/2008 14:17:30
WhenCreated       : 18/12/2008 14:17:30
OriginatingServer : JUDGES.contra.local
IsValid           : True

Get-RoutingGroupConnector | fl - returns nothing. just a new command prompt...

share|improve this answer

I'm on:

Exchange Server 2007

Microsoft Corporation

Version: 08.01.0340.000

I used the following in the syntax in the "Exchange Command Shell":

Set-TransportConfig -MaxReceiveSize 50mb

This changed my "MaxReceiveSize" from 10mb to 50mb, see the Before and After "TransportConfig".

Before:

ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {127.0.0.1}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 10MB
MaxRecipientEnvelopeLimit      : 5000
MaxSendSize                    : 50MB
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True


[PS] C:\Windows\System32>Set-TransportConfig -MaxReceiveSize 50mb

After:

ClearCategories                : True
DSNConversionMode              : UseExchangeDSNs
GenerateCopyOfDSNFor           : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
InternalSMTPServers            : {127.0.0.1}
JournalingReportNdrTo          : <>
MaxDumpsterSizePerStorageGroup : 18MB
MaxDumpsterTime                : 7.00:00:00
MaxReceiveSize                 : 50MB
MaxRecipientEnvelopeLimit      : 5000
MaxSendSize                    : 50MB
TLSReceiveDomainSecureList     : {}
TLSSendDomainSecureList        : {}
VerifySecureSubmitEnabled      : False
VoicemailJournalingEnabled     : True
WritingBrandingInDSNEnabled    : True
Xexch50Enabled                 : True
share|improve this answer

Answer based on Exchange 2003, but probably valid for 2007 as well: there may be size restriction on the individual account (look up user in active directory users & computers -> exchange general -> delivery restrictions).

share|improve this answer

I've found this article useful when it comes to understanding the various message size limits in Exchange 2007.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.