Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got two Redhat5/CentOS systems which share a folder. I'm trying to change the shared folder location, but I ran into this error on the machine on which the folder is mounted...

How can I correct this? I rebooted the computer but to no avail.

Server1 - where its "mounted"

/etc/fstab
IPADDRESS2:/opt/programA/common/files    /srv/server2-share nfs rw,intr    0 0

Server2 - where its "shared"

/etc/exports
/opt/programA/common/files IPADDRESS1/28(rw,insecure,sync,no_root_squash)

Ran the following on Server2

root@server2 [~]# /etc/init.d/nfs start
root@server2 [~]# rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100011    1   udp    875  rquotad
    100011    2   udp    875  rquotad
    100011    1   tcp    875  rquotad
    100011    2   tcp    875  rquotad
    100005    1   udp    892  mountd
    100005    1   tcp    892  mountd
    100005    2   udp    892  mountd
    100005    2   tcp    892  mountd
    100005    3   udp    892  mountd
    100005    3   tcp    892  mountd
root@server2 [~]# /etc/init.d/nfs status
rpc.mountd (pid 10204) is running...
nfsd (pid 10201 10200 10199 10198 10197 10196 10195 10194) is running...
rpc.rquotad (pid 10189) is running...
share|improve this question
    
Forgive the obvious question, but there's no firewall on server2 that might be interfering with this, is there? –  MadHatter Oct 28 '10 at 9:33
    
no - it was working before and then i changed the shared folder (while some services were going on) –  matt74tm Oct 28 '10 at 9:36
    
Awww dangit - i restarted server2 and that solved the problem... looks like the PC-solution works on linux as well!! –  matt74tm Oct 28 '10 at 9:39
1  
No, it means you either needed to restart NFS. Or run "exportfs -a" to reread the exports file. –  Rilindo Oct 1 '11 at 21:22

1 Answer 1

If I understand this correctly you tried to change the location of the share on the server, while a client had the NFS share mounted. In the future I would recommend unmounting the share on any client that has the share mounted. You can use the "showmount" command on the server to make sure that no one has that share mounted.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.