Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have reviewed the previous questions on this and they don't seem to cover what exactly I'm looking for, before I start, I'm no server admin. I'm trying to help get this server up and active and I have got it all going with exception to the SQLite3. The phpinfo displays '--without-sqlite' '--with-libxml-dir=/usr' '--enable-xml' '--with-system-tzdata' '--with-apxs2=/usr/sbin/apxs' '--without-mysql' '--without-gd' '--disable-dom' '--disable-dba' '--without-unixODBC' '--disable-pdo' '--disable-xmlreader' '--disable-xmlwriter' '--without-sqlite3' ' can somebody please advise in simple terms what to do to activate this, I've attempted a yum install.

Thanks in advance,

Sam

share|improve this question
1  
Duplicate - see: serverfault.com/questions/32982/… –  danlefree Oct 28 '10 at 14:50
1  
Also on StackOverflow: stackoverflow.com/questions/2199968/… –  symcbean Oct 28 '10 at 16:32
add comment

3 Answers 3

On CentOS-5 you only need to install the package php53-pdo and sqlite in order to have support for sqlite3

# yum install php53 php53-pdo sqlite

Hope it helps.

share|improve this answer
add comment

The Atomic repository offers a nice, well thought out, compliant with the standard Redhat naming convention and up-to-date bunch of PHP rpms for both Centos 5 & 6. Their official site is this and installing the repository (not the packages) is as simple as

wget -O - http://www.atomicorp.com/installers/atomic | sudo bash

After successfully installing the repository, try

sudo yum update

to get the newest PHP packages from Atomic and then

sudo yum install php-sqlite

to get your sqlite extension installed and automatically loaded.

Note: Atomic offers a lot of updated packages and PHP there is on the 5.3 version. Bear that in mind if you are running 5.3-incompatible applications.

share|improve this answer
add comment

Redhat decided to stop supporting php-sqlite*, but there is a good tutorial here.

share|improve this answer
    
Link is dead. Do you have an alternative? –  jbatista Feb 27 '12 at 16:28
    
The previous link was apparently missing an s in articles: exteon.ro/en/articles/php/compile-extensions –  user139226 Oct 1 '12 at 22:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.