Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I'm trying to set up OWA, but I don't want my users to have to type in https://exchange.foo.com/owa

I've got the http redirect setup to redirect all requests to /owa so that narrows it down to https://exchange.foo.com/

I don't think my users are smart enough to type in that 's' at the end of http every time they want to access their mail. I want it to redirect to the full url with the 'https' and all

I've read this which tells me that I should be able to use http redirect to redirect all traffic to https://exchange.foo.com/owa if I just type in the absolute path to the page. When I do that, I get an error saying that the page isn't redirecting properly.

So I do a URL rewrite. I download the URL rewrite module for IIS and follow the instructions listed here. The page redirects perfectly! Then I'll sign into the forms-based authentication and the same error as before pops up - the page is not redirecting correctly.

Can someone give me a solution that works for them?

share|improve this question
    
Your first method with the HTTP redirect is what you should have to do. If you set that in IIS, you would just go to exchange.foo.com to get redirected. You might also need to make sure Exchange is configured with the correct URL (exchange.foo.com/owa). What version of Exchange, IIS, and Windows Server are you using for these? –  Paul Kroon Oct 29 '10 at 1:50
    
Exchange 2010, IIS7 and Win Server 2008 R2. So you're telling me that setting the http redirect destination to https://exchange.foo.com/owa should work? Firefox still gives me an 'page not redirecting correctly' error when I tried that –  blsub6 Oct 29 '10 at 7:13

1 Answer 1

up vote 1 down vote accepted

I think you're making this a little more complicated than it needs to be.

In the root of your Default Web Site just paste the following HTML code. When a user browses to http(s)://exchange.foo.com they will be redirected to the secure OWA page.

<html>
<head>
<title>Just a second...</title>
<meta http-equiv="refresh" content="0;url=https://exchange.foo.com/owa/" >
</head>
<body>
<h1>Just a second while you are redirected to foo.com's webmail...</h1>
</body>
</html>
share|improve this answer
    
Nice, elegant solution. I also found out that somehow I had set up owa to redirect to itself so it was just redirecting in a loop. When I fixed that, everything worked (HTTP redirect, URL rewrite and your solution) to accomplish the same goal. Thanks :) –  blsub6 Nov 1 '10 at 21:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.