Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up a linux (CentOS 5) box with a samba share on a large network. The network has 2 subnets, one on 192.168/16 and one on 172.18/16. The server lives on the 172.18/16 subnet.

I can ping the server from client Windows XP workstations on both subnets.

When I open the list of workgroup computers, I can see my new server in the list of Workgroup machines from Windows XP client workstations on both subnets.

However, I can access the share from workstations on the same subnet, but when I try to access it from workstations on the other subnet I get a message saying either:

o Windows cannot find the specified resource, or
o Access to this network resource has been disallowed.

I have had a look at the smb.conf file, and there is nothing obvious that would be causing a problem.

What am I doing wrong? Thanks, Rik

share|improve this question
    
Does it work if you access it from a vlient on the same subnet? –  Massimo Oct 29 '10 at 12:29
    
It does work when I try to access the share from clients on the same subnet. I cannot access the share from clients on the other subnet, despite the fact that these clients are able to ping the server in question. –  RikSaunderson Oct 29 '10 at 12:51
add comment

1 Answer

up vote 1 down vote accepted

The problem turned out to be DNS (which is fairly embarassing to be honest). The 172.18/16 half of the network was fine, but the 192.168/16 half of the network couldn't get to the share because it couldn't resolve the name of the server. When we tried going in via the IP address it worked fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.