Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Having some problems installing Virtualmin ( http://www.webmin.com/vinstall.html ). I'm fairly new to Unix terminals and all that, but proficient enough to have been able to install and configure a LAMP stack correctly so far on a MediaTemple (ve). :)

My problem is that I'm trying to install Virtualmin. I've wget the install.sh file into my home directory. I then run the command ./install.sh to launch the installation process. The disclaimer and warnings appear, asks if I want to continue. I hit Y and then:

/tmp directory is mounted noexec. Installation cannot continue.

A bit of googling suggests this is a problem in the /etc/fstab file. When I sudo nano /etc/fstab this is the output:

none /dev/pts devpts rw 0 0

Would someone be able to advise either:

1) How to edit this fstab file to stop /tmp being noexec...? or 2) An easier/different way of installing Virtualmin? I wasn't too sure if there was a yum way of doing it or something.

Cheers!

Jack

share|improve this question

migrated from superuser.com Oct 29 '10 at 12:04

This question came from our site for computer enthusiasts and power users.

    
Woops - posted to the wrong site, silly me! –  Jack Oct 29 '10 at 12:33

1 Answer 1

up vote 1 down vote accepted

Get the RPM here, and install it with rpm --aid webmin-1.520-1.noarch.rpm. It probably will also give you the noexec error - you can fix it by typing mount -o remount,exec /tmp before installation, and mount -o remount,noexec /tmp after.

Copy-and-pasting the below into a root terminal should do all of the above:

wget http://downloads.sourceforge.net/project/webadmin/webmin/1.520/webmin-1.520-1.noarch.rpm?r=http%3A%2F%2Fserverfault.com%2Fquestions%2F196150%2Ferror-installing-webmin%2F196154&ts=1288356140&use_mirror=kent
mount -o remount,exec /tmp
rpm --aid webmin-1.520-1.noarch.rpm
mount -o remount,noexec /tmp
share|improve this answer
    
This doesn't look too promising: 'mount: permission denied' ... :( - thank you for your answer though! Any ideas? –  Jack Oct 29 '10 at 13:58
    
You should be root before attempting the above, as I said. To become root, you can either type su - and enter the root password, if you know it, or sudo -i and enter your password, if sudo is installed and you have permission to use it. –  fahadsadah Oct 29 '10 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.