Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a W2k8 R2 server (actually two controlling the same domain) and want to add another one as DC of a new subdomain. Regardless of whether the DC of the new subdomain is already member of the AD, this operation fails with

The operation failed because: The domain PARENTDOMAIN does not have an established trust with this domain. "The request is not supported." This server has been disjoined from domain "PARENTDOMAIN".

dcpromo.log says:

10/29/2010 14:39:11 [INFO] Creating a parent trust relationship on domain PARENTDOMAIN
10/29/2010 14:39:11 [INFO] Creating trusted domain object on parent
10/29/2010 14:39:11 [INFO]  DnsDomain: PARENTDOMAIN
10/29/2010 14:39:11 [INFO]  Flat name: SUBDOMAIN
10/29/2010 14:39:11 [INFO]  Direction: 3
10/29/2010 14:39:11 [INFO]  Type: 2
10/29/2010 14:39:11 [INFO]  Attributes: 0x20
10/29/2010 14:39:11 [INFO] Creating a trust relationship with domain SUBDOMAIN
10/29/2010 14:39:11 [INFO] Creating trusted domain object on child
10/29/2010 14:39:11 [INFO]  DnsDomain: PARENTDOMAIN
10/29/2010 14:39:11 [INFO]  Flat name: PARENTDOMAIN
10/29/2010 14:39:11 [INFO]  Direction: 3
10/29/2010 14:39:11 [INFO]  Type: 2
10/29/2010 14:39:11 [INFO]  Attributes: 0x20
10/29/2010 14:39:11 [INFO] Child LsaCreateTrustedDomainEx on PARENTDOMAIN failed with 0xc00000bb
10/29/2010 14:39:11 [INFO] Error - The domain PARENTDOMAIN  does not have an established trust with this domain.

I actually have no clue what I should do, because the new subdomain obviously does not have "an established trust" with the parent domain just after it was created.

Btw. I also checked the domain policy and Administrators are allowed add trust for delegation. The two DCs seem also to work properly according to dcdiag.

Thanks in advance, Christoph

share|improve this question
    
Just a tip...If you would edit this, then highlight the LOG area and hit the CODE button it will keep it all from running together like that...help everyone read it a little better. The CODE button looks a couple of 1's and 0's just above the text area beside the quotation marks. –  REW Oct 29 '10 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.