Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do you disable CPU power management scaling in Windows Server 2008 R2?

After setting the Control Panel, Power Management plan to performance and then rebooting -- CPUID's Cpu-Z still shows the clock speed being scaled.

alt text

share|improve this question
    
Going to check the BIOS when I get a chance, I have a vague memory of seeing scaling settings in BIOSes before. These are Dell R710s. –  Kyle Brandt Oct 29 '10 at 20:13

2 Answers 2

up vote 22 down vote accepted

There are 3 Main BIOS settings in the Dell R710 that control this under Power Management:

OS Control sets the CPU power to OS DBPM, the fan power to Minimum Power, and the memory power to Maximum Performance. In this setting, all processor performance information is passed from the system BIOS to the operating system for control. The operating system sets the processor performance based on processor utilization.

Active Power Controller sets the CPU power to System DBPM, the fan power to Minimum Power, and the memory power to Maximum Performance. The BIOS sets the processor performance based on processor utilization.

Maximum Performance sets all fields to Maximum Performance.

Source: http://support.dell.com/support/systemsinfo/document.aspx?c=us&cs=555&l=en&s=biz&~file=/systems/pet410/en/hom/html/syssetup.htm

We had it set to "System DBPM" so it was ignoring the OS settings.


It is worth noting that this was digging into why some of our full text SQL queries were taking so long. After this change we observed that these queries dropped from an average of 1285 ms to 335 ms.

share|improve this answer
    
damn, was AFK, this one was right up my street :) –  Chopper3 Oct 29 '10 at 21:11
    
Yep... Saw this with the first R710's I put in. It was counter-intuitive to me that the machine would be shipped with sub-optimal performance settings as the default. I don't know if the default was tweaked in later BIOS releases or not, but I've just gotten into the habit of checking on all the R-series Dell servers now. –  Evan Anderson Oct 30 '10 at 15:13

For posterity, here are the settings needed for HP servers (as of the DL360G6 I just checked)

The main one:

  • Power Management Options
    • HP Power Regulator
      • HP Dynamic Power Savings Mode Vary CPU frequency and power setting based on load. Ignores OS settings. Default
      • HP Static Low Performance Mode Tunes CPU frequency and power settings to their lowest levels.
      • HP Static High Performance Mode Locks CPU frequency and power settings to their highest levels. For performance.
      • OS Control Let the OS handle it.

The other one:

  • Power Management Options
    • Minimum Processor Idle Power State
      • C6 Deep Power Down
      • C3 Sleep mode
      • C1E Enhanced Low Power Mode
      • No C-States Disable all such states.
share|improve this answer
    
The first time I tried disabling C1E and C-States, the result was that the CPU was stuck at the lowest Frequency and would not scale up. This might make perfect sense ... don't totally understand those settings ... –  Kyle Brandt Oct 29 '10 at 21:48
    
@Kyle Could be they don't like working together. Or the OS should just do it. ACPI is tricky. –  sysadmin1138 Oct 29 '10 at 21:56
    
@kyle Dell shipped it to us with bad BIOS settings. The two sane options would be 1) ship with max performance override or 2) ship with "let the OS control it" -- neither was true for us, so we had the worst of both worlds.. –  Jeff Atwood Oct 29 '10 at 23:32
    
@Jeff In my experience, servers have been shipping with "green" settings lately. And of course HW vendors set things to trust their own power-balancing algorithms over silly OS settings. –  sysadmin1138 Oct 30 '10 at 0:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.