Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hello I have just installed Windows 2008 web server to have a development/test site on my office.

In the test network I only have 2 machines:

  • Windows server 2008 Web Edition
  • Vista x64 client machine with Visual Studio

The client and the server are networked using a NETGEAR router.

I have enabled Remote desktop on the server and when I try to connect to it within the Vista client I get the credential window as in the following screenshot.

alt text

But even if I write the correct credentials I am not able to remote login on the server.

Where am I doing wrong?

Update 1

I have even tried to create a folder share on the server. But I am not able to access it for the same reason. User or password invalid it says. But this is impossible as I am logging in the server with the same credentials.

alt text

Update 2

If I try to browse the network from the RDP client I receive a message saying that there are no server running Terminal Services in my network.... :O alt text

share|improve this question

3 Answers 3

up vote 0 down vote accepted

Have you checked the firewall (and file sharing) settings on the Windows 2008 Server?

share|improve this answer
    
I have completely disabled the firewall. –  Lorenzo Oct 31 '10 at 21:39
    
A possible way to check for a credentials issue may be to issue a "dir \\127.0.0.1\c$ /user:VIMBooNET\administrator" command on the server itself. "VIMBOONET\administrator" is based off of your screen-shot. –  user48838 Nov 1 '10 at 1:07
    
Got a message: Invalid switch "/user" –  Lorenzo Nov 1 '10 at 1:29
    
This is on the Windows 2008 Web Server? –  user48838 Nov 1 '10 at 3:25
    
Yes. I have executed the command on the server. –  Lorenzo Nov 1 '10 at 12:43

You are sending the wrong credentials OR using an outdated RDB client. Try running windows update. I am not sure that Vista already supports the new security features that 2008 R2 brings in as default settings. I know most open source / alternative / linux rdp clients have a problem there.

Additionally, prefix with domain or machine name (plus ). If your machine is in a domain sometimes things go wrong there (and it tries your domain name, which obviously will not work).

What error do you get? You are so nice to show us what you enter (although we do not speak italian here - thanks), but you dont say anything about the errors.

Does it just time out? Check firewall. It is a simple TCP connect, but still. Also the ports must be open on the other side (the server).

Do you get a password / secureity error? What is it?

share|improve this answer
    
I just installed the machine yesterday. before configuring in this pseudo network I have done all the necessary updates. The machine is not in a domain as I just wan to use it as it would be on internet facing. I am using the hostname\administrator to connect. I have completely disabled the firewall. There-s no error except what you can see on the screenshot that can be translated with "Connection attempt failed"; It says that my username or password are invalid but this is not true because I can login on the server desktop regularly... –  Lorenzo Oct 31 '10 at 21:45

Do you have Remote Desktop enabled on the server? Right-click on the Computer icon > Properties > Remote Settings. It should automatically add an exclusion to the firewall if my memory serves me correctly.

You can test that it's working by going to the command prompt and typing netstat -aon | find ":3389" which will return something like this: TCP 0.0.0.0:3389 0.0.0.0:0 LISTENING 1716

You can also test that the firewall is open from another machine by telnet <hostname or IP> 3389 and you should get a blank cursor blinking (you can exit by hitting CTRL-] and then typing quit).

share|improve this answer
    
@gravyface: Yes it is enabled even because otherwise I would'nt get a login window, is'nt it? Anyway I have checked just now. The firewall is disabled for every network profile. –  Lorenzo Oct 31 '10 at 21:47
    
@gravyface: Yes I have Remote desktop enabled from the Remote Settings options but the server is not running the Terminal Server Role as it is a Web Edition and does not have that role. How I can do? –  Lorenzo Oct 31 '10 at 22:02
    
Newer versions of the RDP client will ask for the credentials before it establishes a connection. –  gravyface Oct 31 '10 at 22:41
    
Thanks for the tip on the newer version of RDP client. I did not know. I have tried the netstat command and i get two rows. First one is like your sample but with 1116 port number. the second one is TCP [::]:3389 [::]:0 LISTENING 1116 –  Lorenzo Oct 31 '10 at 23:05
    
1116 is the process ID; yours looks correct. –  gravyface Oct 31 '10 at 23:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.