Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The cron configuration of bfd appears to be wrong

MAILTO=
SHELL=/bin/bash
*/3 * * * * root /usr/local/sbin/bfd -q

It is the original setting created by the installation.

The cron.log gives this error - Error: bad minute; while reading /etc/cron.d/bfd but it looks perfectly fine to me.

share|improve this question
1  
What version of cron? What OS? Not all versions of cron out there accept the */3 syntax. –  freiheit Oct 31 '10 at 18:56
    
I am using Ubuntu Hardy 8.04.4 –  vfclists Oct 31 '10 at 19:53

3 Answers 3

up vote 2 down vote accepted

remove the first two lines

share|improve this answer

Setting environment variables in your crontab files, as in your example...

MAILTO=
SHELL=/bin/bash

...is only supported in certain versions of cron. In particular, crond by Paul Vixie, which is typical on many Linux distributions, supports this syntax. It looks like Hardy may be using something else. Looking at the crontab(5) man page should give you more details on the syntax supported by your locally installed version of cron.

If you need to ensure that environment variables are set correctly, you can set them on the individual crontab command line, like this:

*/3 * * * * root env MAILTO= SHELL=/bin/bash /usr/local/sbin/bfd -q
share|improve this answer

I had this problem - setting environment variables is supported by your version of cron, but instead of

 MAILTO=

use

 MAILTO=""
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.