Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We've got a Hyper-V environment where the time is running around like a headless chicken.

Some days when I come in, it's 10 minutes slow. Other days, it's 5 minutes fast. Today it's over 30 minutes slow. Every day I re-sync the time manually, and 24 hours later it's all out of whack again.

I tried running the following command:

w32tm /config /manualpeerlist:"time.windows.com,0x01 1.ca.pool.ntp.org,0x01 2.ca.pool.ntp.org,0x01" /syncfromflags:MANUAL /update

When I run this on our Hyper-V environment (on the DCs and the hosts) it returns the exact same time that the clocks are currently set to. When I run it on a non-domain environment, it returns the correct time (I went and manually broke the date/time on the machine to test). All my timezones are set correctly (GMT+10).

Any ideas why this might be?

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

It may be the Kerberos role/relationship that is keeping the DCs/servers from actually adjusting their time corrections.

http://support.microsoft.com/kb/816042

share|improve this answer
    
Thanks. I've applied the fixit patch that they supplied, we'll see if it still happens tomorrow morning (already fixed it for today) –  Mark Henderson Oct 31 '10 at 21:26
    
It sounds like it is promising... –  user48838 Nov 1 '10 at 0:44
add comment

Try disabling the "time synchronization with the host through Integration Services."

This TechNet article about "Deployment Considerations for Virtualized Domain Controllers" has this to say in the section regarding "Time service":

For virtual machines that are configured as domain controllers, disable time synchronization with the host through Integration Services. Instead, accept the default Windows Time service (W32time) domain hierarchy time synchronization.

Host time synchronization makes it possible for guest operating systems to synchronize their system clocks with the system clock of the host operating system. Because domain controllers have their own time synchronization mechanism, host time synchronization must be disabled on virtual machines that are configured as domain controllers. If domain controllers synchronize time from their own source and also synchronize time from the host, the domain controller time can change frequently. Because many domain controller tasks are tied to the system time, a jump in the system time could cause lingering objects to be left in the directory and replication to be stopped.

You can disable host time synchronization in the virtual machine settings in the Integration Services section of the Hyper-V Manager by clearing the Time Synchronization check box.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.